SRST First Time

Unanswered Question
Aug 13th, 2009

Hello All,

I have configured a SRST on a 2801 router using MGCP in normal mode.

I have configured UCM 6.1 for a Device Pool with this SRST and configured the DP in a phone. After resetting all, the SRST does not appears in the list of CMs in the phone. Should it?

Also, the phone does not register with SRST when I stop Call Manager service at UCM. Any help?

call-manager-fallback

max-conferences 4 gain -6

transfer-system full-consult

user-locale ES

ip source-address 10.10.10.10 port 2000

max-ephones 20

max-dn 20

system message primary PRUEBAS

time-format 24

date-format dd-mm-yy

!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
aramos17428 Thu, 08/13/2009 - 22:31

Can you please post the whole config?

make sure you have

ccm-manager fall-back mgcp

!

application

global

service alternate Default

!

Looking at your whole config will be better.

Armando

mcecilia Thu, 08/13/2009 - 23:25

I tested that commands and did not worked. This is the config:

Current configuration : 2872 bytes

!

! Last configuration change at 08:50:11 CEST Fri Aug 14 2009

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname cumg02

!

boot-start-marker

boot system flash c2801-ipvoice-mz.124-24.T.bin

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

clock timezone cest 1

clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00

clock calendar-valid

network-clock-participate wic 1

ip source-route

!

!

!

!

ip cef

no ip domain lookup

ip domain name test.com

no ipv6 cef

ntp update-calendar

ntp server 128.90.80.1

multilink bundle-name authenticated

!

!

!

isdn switch-type primary-qsig

!

!

!

!

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g711ulaw

codec preference 3 g729r8

!

!

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

dsp services dspfarm

!

!

application

global

service alternate Default

!

!

!

!

!

controller E1 0/1/0

pri-group timeslots 1-31 service mgcp

!

!

!

!

!

interface FastEthernet0/0

ip address 10.10.10.10 255.255.255.224

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1/0:15

description QSIG a Nortel Labo

no ip address

encapsulation hdlc

isdn switch-type primary-qsig

isdn timer T310 120000

isdn protocol-emulate network

isdn incoming-voice voice

no cdp enable

!

interface Serial0/2/0

no ip address

shutdown

clock rate 2000000

!

interface ATM0/3/0

no ip address

shutdown

no atm ilmi-keepalive

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.10.10.1

!

!

ip http server

!

disable-eadi

!

!

control-plane

!

!

!

voice-port 0/1/0:15

cptone ES

!

ccm-manager fallback-mgcp

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 10.10.20.10

ccm-manager config

!

mgcp

mgcp call-agent 10.10.20.10 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

mgcp default-package mt-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 ecm

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

!

!

call-manager-fallback

max-conferences 4 gain -6

transfer-system full-consult

user-locale ES

ip source-address 10.10.10.10 port 2000

max-ephones 20

max-dn 20

system message primary PRUEBAS

time-format 24

date-format dd-mm-yy

!

!

line con 0

login local

line aux 0

line vty 0 4

privilege level 15

login local

!

scheduler allocate 20000 1000

end

mcecilia Thu, 08/13/2009 - 23:26

May be the problem is not on the SRST. Perhaps, the phone does not try to find the SRTS. What do you think?

iptuser55 Fri, 08/14/2009 - 03:52

A side issue, you need to add MAX-DN XXXX DUAL-LINE if you use Full-Consult as the phone need two lines to do this otherwise it will drop back to a blind transfer.

Is the Router on the same CUCM as the phones as you need both the phone and Router not register to CUCM for SRST to kick in

Actions

This Discussion