IP Communicator in VMWare (no Sound Card)

Answered Question
Aug 14th, 2009
User Badges:

I am trying to use IP Communicator on a VMWare machine, just for the purpose to perform some tests with CDR's/Billing.


However, since the VMWare machine does not support virtualization of the sound card, IP Communicator is not even launching.


Is there a way for IP Communicator to work (launch and establish call), even without any audio device?

I don't care about the audio, I just want to establish call and look at the Call Detail Records.


Thanks.

Correct Answer by timurbayazitov about 7 years 10 months ago

Hello,

"Virtual Audio Cable" worked fine for me when I needed to run CIPC on VMware. You can download it here: http://software.muzychenko.net/eng/vac.html ,demo version is quite enough.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
j.house Thu, 03/10/2011 - 10:02
User Badges:

I downloaded the VAC trial app, but while I can get sound out of IPC while in a VMWare View sesssion I cannot get a Microphone to work.  Not sure if it is a limitation of the trial license as on the receiving end I hear "Trial" being spoken over and over.  not sure if the full version would actually pass the mic feed or not.


Thoughts?

Jayant Kohli Wed, 04/06/2011 - 02:32
User Badges:
  • Cisco Employee,

Hey...


I am unable to get the CIPC up on VMware. I downloaded the trial version and installed it and it still gives me error message" There are no compatible sound devices installed on this computer"

Please suggest.



regards

Jayant

Rui Carlos Antunes Wed, 04/06/2011 - 02:42
User Badges:

Hello Jayant.


Have you tried "Virtual Audio Cable"? It worked for me. It creates virtual sound resources, that CIPC can consider as compatible sound devices.


Good luck.

Jayant Kohli Wed, 04/06/2011 - 03:24
User Badges:
  • Cisco Employee,

Hey Rui,


Thanks for the reply.

I installed Virtual Audio cable and still no go for me.

Could it be the version issue of CIPC?

I can lower down the version of CIPC to the one you are using to see to check if its the version issue.

Also, i have installed WYSE Multimedia Support on VMware but no luck.

Please let me know the version of CIPC and VMware.


Regards


Jayant

Rui Carlos Antunes Wed, 04/06/2011 - 07:38
User Badges:

I'm using VMWare Server 1.0.8 (yes, it's a very old version) and CIPC 2.1 (not very recent either).

I don't know if there is a difference with more recent versions of CIPC or VMWare...

j.house Wed, 04/06/2011 - 07:46
User Badges:

Can you tell me what your settings are for  the virtual audio cable...I am having a difficult time getting this to work.  I can get IPC to see a sound card, but I cannot get the Microphone to map to IPC.


Thanks!

Rui Carlos Antunes Wed, 04/06/2011 - 08:09
User Badges:

Hello Jayant.


Sorry, I misunderstood your problem.

I'm also unable to get the microphone to work. However, since I have CIPC on a VM just for call setup troubleshooting purposes (not for real audio conversation purposes), this is not a problem to me.

So, I do not have a solution for the microphone problem, sorry.


Good luck!

Jayant Kohli Wed, 04/06/2011 - 22:13
User Badges:
  • Cisco Employee,

Hey Rui,


I am unable to get the CIPC to work. It never launces and gets stuck at " starting audio " and then the error.

I am sure it is related to audio drivers it is looking for but i am not sure how virtual cable would work.

Can you tell me what the settings for virtual cable should be?


Thanks,

Jayant

bcali Fri, 08/10/2012 - 13:39
User Badges:

On trick I have found is to put a link to the IPCommunicator in your startup folder so it is running before you RDP to the workstation.

Alexandr Alakin Mon, 06/10/2013 - 20:36
User Badges:

Just in case people still need to run CIPC in virtualized Windows XP or Windows 7


By default RDP uses setting "Bring remote computer sound to this computer" (XP) or "Play on this computer" (7) and CIPC is not working with this settings even if virtual sound card is installed (only Microsoft RDP Audio Driver is available in audio settings in this case and CIPC ignores it).


So before connecting via RDP to virtualized Windows (when entering remote computer address) click "Options" and on "Local Resources" tab:

for Windows XP: choose "Leave at remote computer";

for Windows 7: Settings => Play on remote computer.

Also in Windows 7 CIPC should be run in compatibility mode to be able to use virtual audio card: Right click on CIPC shortcut => Properties => Compatibility tab => Check "Run this program in compatibility mode for:" => Windows XP (Service Pack 3).


Now after connecting to remote Windows CIPC will be able to find suitable audio devices (Virtual Audio Cable is working just fine ).


HTH,

Alexandr


Message was edited by: Alexandr Alakin (added solution for virtualized Windows 7)

Actions

This Discussion