EIGRP Stub & Query Packets

Unanswered Question
Aug 15th, 2009

Hi Experts,

I am configuring EIGRP Stub routing as below:

R2 - R0 - R1

R0 is configured as EIGRP STUB. My understanding of EIGRP is when a router is configured as EIGRP, it informs the peer neighbors that he is the EIGRP and thus those neighbors will not send any QUERY packets to this STUB Router. Is this correct?

If that is the case i expected R1 will not get any QUERY Packets when Loop 1 interface in R2 made down. To my surprise, I have seen the debug message (pl.find the attached file) stating QUERY packet is reaching R0 and even to R1.

Why it is behaving like this. Is my understanding is not right?

Kindly help. Thanks in advance


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Peter Paluch Sat, 08/15/2009 - 05:31

Hello Sairam,

I have configured a three-router topology with routers connected in line and the one on the left being configured as EIGRP stub. I have made changes to the interfaces on the middle and right router but I can confirm that the left router never received a Query.

Also, please, try to use the command debug eigrp packet query reply update on your EIGRP stub router and attach the debugs here. This should show us more what is going on.

As a rule, if a neighbor of a stub router recognizes that it is a stub router (use the show ip eigrp nei detail on the neighboring routers to check it) it will never send it a Query packet. If it does not recognize it as stub, it will send it a Query but the stub router will immediately reply with an infinite metric.

Originally I requested for a more precise description of your network but I have overlooked that you have actually described it in your original post. Sorry. But I would be interested in seeing that debug output, still :) Thanks!

Best regards,



This Discussion