iBGP:

Answered Question
Aug 15th, 2009

Should I run iBGP between both routers, in site A and site B.

ISP(AS 3000) is the primary MPLS for all sites (A,B,C&D).

Please advise.

Attachment: 
Correct Answer by Jon Marshall about 7 years 6 months ago

Colm

Apologies for not explaining this very well.

THe key thing to understand is that a more specfic route is always chosen over a less specfic route and a default-route is the least specific route you can have.

So lets look at the solution from the perspective of Site A, although exactly the same logic applies to site B.

At the moment you are redistributing BGP into EIGRP on both R1_A and R2_A. So the networks you advertise from Site B via BGP will be received by R1_A and R2_A and redistributed into EIGRP.

So the internal devices within Site A see 2 possible routes to each network within site B ie. via R1_A & R2_A.

Now the idea i suggested was to continue to redistribute the networks received from BGP into EIGRP at site A on R1_A. Lets also assume that you stopped the redistribution on R2_A. With this setup your internal devices in Site A would only see one path to Site B and that would be via R1_A.

In normal conditions this is the path you want traffic to take. But obviously if R1_A fails then there is no other path being advertised to Site B. Now you can't just add redistribution of BGP into EIGRP back on R2_A because then the traffic can take either path and you only want it to take R1_A under normal conditions.

So you don't redistribute the networks in site B into EIGRP on R2_A. What you do is add a default route on R2_B and then redistribute this into EIGRP. This default-route will have the same metric/AD as the other routes redistributed on R1_A so the internal devices within Site A will see the specific network routes redistributed from R1_A and the default route redistributed from R2_A.

And because a more specific route is always chosen over a less specific route the traffic will always go via R1_A and not R2_A. If the R1_A link fails then the internal devices within Site A still have the default route via R2_A to get to Site B. If R1_A link then comes back up the more specific routes will be redistributed into EIGRP again and traffic will take the path via R1_A.

Now you could actually just change the metrics when you redistribute on R2_A but i wasn't sure of the complete topology of your networks in Site A and B and metrics can take a fair bit of tweaking sometimes to make sure traffic is using the right path. The default route solution does not rely on tweaking the metrics and so, in my opinion, is easier to implement.

Hope this explains it in more detail. If you have further questions or i have missed your point then let me know.

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Peter Paluch Sat, 08/15/2009 - 13:11

Hi,

I think we need more information about what your needs and requirements are. There is no universal rule whether to run BGP or not - it depends on what you really need.

I gave a short glimpse on the drawing you have attached. Do I understand it correctly that the R1_A and R1_B are in AS 70000 while the R2_A and R2_B are in AS 65000?

Further on, are you asking about peering the R1_A and R2_A together, and similarily, about peering the R1_B and R2_B? In general, I would say - yes, have them peered together but if I read the drawing correctly, they are in different ASes (70000 vs. 65000) so you won't be able to run iBGP between them.

Best regards,

Peter

Jon Marshall Sat, 08/15/2009 - 13:23

Colm

Is this a follow on from the previous post ?

If so apologies for not getting back on that one, i must have missed your latest reply.

If you are still trying to influence the paths traffic takes from site A to site B and vice-versa then i'm not sure how running IBGP between R1_A & R1_B and R2_A & R2_B would help.

What you really want is to run IBGP between R1_A and R_2A and R1_B and R2_B but as Peter points out you can't do that as they are in different ASs.

Is there a reason you don't want to use the original solution posted in the other thread ?

Peter - for your reference this is the other thread, please feel free to dive in :-)

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=LAN%2C%20Switching%20and%20Routing&topicID=.ee71a04&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cd44a6c

Jon

colmgrier Sat, 08/15/2009 - 14:07

Thanks Jon & Peter for reply.

Jon this is a follow on from previous post.

Apologies I can see now why I cant run iBGP between the routers in site A & B. Lack of my BGP knowledge!!

The main reason I didnt want to use the original solution posted in the other thread, is that I dont fully understand the solution.

I will need to setup in lab before applying to live network. Just to get my head around it.

Thanks again.

colmgrier Sat, 08/15/2009 - 14:27

Jon,

Can you explain how default route will work on R1_B.

What is the metric of the below of the below default route when distributed into EIGRP.

ip route 0.0.0.0 0.0.0.0 89.124.100.5

Site A

### R1_A ###

interface GigabitEthernet0/0

description "LAN"

ip address 10.1.20.5 255.255.255.0

duplex auto

speed auto

interface GigabitEthernet0/1

description "MPLS (Primary)"

ip address 89.124.200.6 255.255.255.252

router eigrp 90

redistribute bgp 70000 metric 128 50 255 100 1500

network 10.1.20.0 0.0.0.255

no auto-summary

router bgp 70000

no synchronization

bgp log-neighbor-changes

network 10.1.20.0 mask 255.255.255.0

network 10.1.21.0 mask 255.255.255.0

neighbor 89.124.200.5 remote-as 3000

no auto-summary

### R2_A ###

interface GigabitEthernet0/0

description "LAN"

ip address 10.1.20.6 255.255.255.0

duplex auto

speed auto

interface GigabitEthernet0/1

description "MPLS (Backup)"

ip address 89.124.100.6 255.255.255.252

ip route 0.0.0.0 0.0.0.0 89.124.100.5

router eigrp 90

redistribute static

redistribute bgp 65000 metric 128 50 255 100 1500

network 10.1.20.0 0.0.0.255

no auto-summary

router bgp 65000

no synchronization

bgp log-neighbor-changes

network 10.1.20.0 mask 255.255.255.0

network 10.1.21.0 mask 255.255.255.0

neighbor 89.124.100.5 remote-as 2500

no auto-summary

Correct Answer
Jon Marshall Sun, 08/16/2009 - 02:42

Colm

Apologies for not explaining this very well.

THe key thing to understand is that a more specfic route is always chosen over a less specfic route and a default-route is the least specific route you can have.

So lets look at the solution from the perspective of Site A, although exactly the same logic applies to site B.

At the moment you are redistributing BGP into EIGRP on both R1_A and R2_A. So the networks you advertise from Site B via BGP will be received by R1_A and R2_A and redistributed into EIGRP.

So the internal devices within Site A see 2 possible routes to each network within site B ie. via R1_A & R2_A.

Now the idea i suggested was to continue to redistribute the networks received from BGP into EIGRP at site A on R1_A. Lets also assume that you stopped the redistribution on R2_A. With this setup your internal devices in Site A would only see one path to Site B and that would be via R1_A.

In normal conditions this is the path you want traffic to take. But obviously if R1_A fails then there is no other path being advertised to Site B. Now you can't just add redistribution of BGP into EIGRP back on R2_A because then the traffic can take either path and you only want it to take R1_A under normal conditions.

So you don't redistribute the networks in site B into EIGRP on R2_A. What you do is add a default route on R2_B and then redistribute this into EIGRP. This default-route will have the same metric/AD as the other routes redistributed on R1_A so the internal devices within Site A will see the specific network routes redistributed from R1_A and the default route redistributed from R2_A.

And because a more specific route is always chosen over a less specific route the traffic will always go via R1_A and not R2_A. If the R1_A link fails then the internal devices within Site A still have the default route via R2_A to get to Site B. If R1_A link then comes back up the more specific routes will be redistributed into EIGRP again and traffic will take the path via R1_A.

Now you could actually just change the metrics when you redistribute on R2_A but i wasn't sure of the complete topology of your networks in Site A and B and metrics can take a fair bit of tweaking sometimes to make sure traffic is using the right path. The default route solution does not rely on tweaking the metrics and so, in my opinion, is easier to implement.

Hope this explains it in more detail. If you have further questions or i have missed your point then let me know.

Jon

colmgrier Sun, 08/16/2009 - 08:26

Hi Jon,

The above explaination is excellent and I now fully understand your solution for my network in previous posts.

Thanks a million.

Colm

Actions

This Discussion