SRW224G4 firmware upgrade problem!

Unanswered Question
Aug 16th, 2009

I have SRW224G4 with the following details:

Hardware version: 00.03.00

Boot version: 1.0.2

Firmware version: 1.2.1.b

I need to upgrade to 1.2.2 so it'll support the Gbic fibre module but I had no luck upgrading it.  Please let me know first which ros image file I should be using?  Two are available: fesm-12216.ros which is 1.2.2a  and ls_106-12216.ros which is 1.2.2b.  I tried 1.2.2b but I couldn't go anywhere.  First I lost webview then after a few reboots it came back but firware stays at 1.2.1b.

What should I do here?

Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
chrcoope Mon, 08/17/2009 - 09:48

Boot version 1.0.2 does in fact use 1.2.2b. If the Web Interface (WI) is non responsive by its IP address that you set, try the factory default IP of 192.168.1.254. you will have to place your workstation in that subnet to talk to it by the way. Should this fail, you will need your rollover/console cable that came with the device so that you can connect to the console. Hyperterminal settings are 38400 8,N,1 with NO hardware flow control. You have two choices now, login and make changes, or do an xmodem transfer.

The xmodem transfer process will require a reboot of the device while you are consoled in. As the device begins its POST, by displaying test names with PASS, PASS, PASS as the results, press the escape key (or ctrl+u in some cases). Press it only once or it will bounce out of the menu you are trying to get to. Once here select upload file (select this quick, it times out fast). It will begin printing strange characters on the console screen meaning it is awaiting your xmodem transfer. From hyperterm, you can send it a file via XMODEM by selecting transfer, send file, select xmodem from the pull down and then browse to your firmware image and click send. Estimated time, 35 minutes or less for upload.

If you have any more trouble, please do not hesitate to ask.

Regards,

Christopher

ravit2009 Fri, 08/21/2009 - 05:51

Thanks Chris.  Xmodem eventually did the trick.  I now have 1.2.2b but the switch doesn't seem to work with MFEFX1.  It's supposed to work with SRW224G4 on firmware 1.2.2 though.  Are you aware of any known compatibility issue?

chrcoope Fri, 08/21/2009 - 09:03

This should be compatible with both A and B as long as it is 1.2.2. Have you turned off auto negotiation and statically configured the line speed for 100 meg FD? Try that at both ends and let me know what you get. I do not have any of the SFPs available at the moment or I would be happy to test this for you.

Regards,

Chris

ravit2009 Thu, 08/27/2009 - 18:02

Hi Chris,  tried that but still no luck... Should I try 1.2.2a firmware instead?  Or it will stuff up the Switch?  Funny thing is I called Linksys support line today and was told those devices are not compatible with each other.  Could you confirm that?

Thanks!

chrcoope Fri, 08/28/2009 - 07:40

1.2.2a will not work with your hardware version. Here is the "Quick Installation" guide. On page four, it shows your switch as compatible with firmware 1.2.2. The "a" and "b" only denote hardware versions supported.

What kind of SFP and switch are at the other end? What color/type of fiber you are using? Do you have any extra fiber, SFPs or switches for testing?

Regards,

Chris

johnafields Fri, 04/23/2010 - 16:04

Here it is, April 2010, and I have the EXACT same problem.  And the only reason I found an answer is becuase some other user included the firmware and model number in his post. I cannot express how frustrating dealing with the cisco website has been.

Since the post is soooo old the link to the configuration guide is no longer valid.  AWESOME.  And I have been trying for almost an hour to find a way to access said guide for this switch, because I really want to read it, and it is sufficiently web2.0'd out of the search indexes.  NOW I CANNOT FIND THE DAMN DOC FOR THIS SWITCH.

WTF is up with this website?  Is there an FAQ that tells a person HOW to think like cisco to use the site to actually get results?  I'm sorry but it Friday afternoon and I would be going home to my babies RIGHT NOW if it weren't for this waste of time cisco calls a website.  I swear by and to GOD the next time I have any say in the matter we are going with Dell or HP.  This is about the last time cisco switches are going to be able suck my time away from my family.

I am coming back to this on Monday after I have cooled off.  But I bet I still won't be able to find the doc without actual human intervention.  Any pity anyone can give me will be appreciated.  This website has reduced me to this.

UPDATE: in my rage I kept trying to use cisco.com to get at it..

Use google.  For as long as the link works...

http://ciscosystems.com/en/US/docs/switches/.../SRW-US_v10_UG_A-Web.pdf

Cheers.

JF

johnafields Wed, 04/28/2010 - 11:31

Thank you for the reply!  But...how am I, as a simple customer, supposed to reproduce your result?

Starting from the home page: How many clicks should it take, and what keywords would I need to hunt for?

I mean: If I had to find it again next week, or for a model number one letter off, I have complete confidence I would still end up as frustrated as before.

In all my iterating over cisco.com I NEVER got to that page.

The only navigation method that worked for me was using "the google", or "the Stephanie".

Thanks!

John

streaves Wed, 04/28/2010 - 12:32

Understand your frustration. Recommend you start your visits on the Small Business sub site -- www.cisco.com/smallbusiness if you're working with Small Business products. Our switches all have pages with vanity URLs. Note the /go/smallbizmanagedswitches. You can also use this for unmanaged switches, smart switches, routers, wireless. Here's a list, just remember to prepend with www.cisco.com/

go/continuousdataprotection
go/smallbizphones
go/smallbizmanagedswitches
go/smallbiznetworkaccessories
go/smallbiznetworkstorage
go/smallbizrouters
go/smallbizsmartswitches
go/smallbizunmanagedswitches
go/smallbizcameraaccessories
go/smallbizcameras
go/smallbizvoiceaccessories
go/smallbizvoicegateways
go/smallbizvoicesystems
go/smallbizwireless

Also recommend you bookmark the pages you visit frequently.

Again -- hope this helps.

Thanks,

--Stephanie

Actions

This Discussion