LDP over OSPF- tunnel not coming up

Unanswered Question
Aug 17th, 2009
User Badges:

Here are the two configs.



The OSPF neighbor relationship shows up. A show interfaces serial1/0/0 detail shows:


bottom-7507#show mpls interfaces s1/1/0 det

Interface Serial1/1/0:

IP labeling enabled (ldp):

Interface config

IGP config

LSP Tunnel labeling not enabled

BGP labeling not enabled

MPLS operational

Optimum Switching Vectors:

IP to MPLS Turbo Vector

MPLS Turbo Vector

Fast Switching Vectors:

IP to MPLS Fast Switching Vector

MPLS Turbo Vector

MTU = 1580


any suggestions?



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
shivlu jain Mon, 08/17/2009 - 07:16
User Badges:
  • Silver, 250 points or more

check the show mpls ldp interface and check the router id. I think router id not mentioned forcefully and taking it another.


regards

shivlu jain

gregwoodson Mon, 08/17/2009 - 07:23
User Badges:

I went ahead and put the router id in both routers. Here is the message i got:


top-7507#show mpls ldp neigh

Peer LDP Ident: 10.0.0.2:0; Local LDP Ident 10.0.0.1:0

TCP connection: 10.0.0.2.15132 - 10.0.0.1.646

State: Oper; Msgs sent/rcvd: 4522/4527; Downstream

Up time: 2d17h

LDP discovery sources:

Serial1/1/0, Src IP addr: 10.0.0.2

Addresses bound to peer LDP Ident:

10.0.0.2 10.255.0.2


There are still no mpls routes being shared as of yet after i cleared the ospf process.

shivlu jain Mon, 08/17/2009 - 07:32
User Badges:
  • Silver, 250 points or more

please share the outputs of show mpls ldp discovery


regards

shivlu jain

gregwoodson Mon, 08/17/2009 - 07:35
User Badges:

Router A:


top-7507#sh mpls ldp disc

Local LDP Identifier:

10.0.0.1:0

Discovery Sources:

Interfaces:

Serial1/1/0 (ldp): xmit/recv

LDP Id: 10.0.0.2:0; no host route


Router B:


bottom-7507#sh mpls ldp disc

Local LDP Identifier:

10.0.0.2:0

Discovery Sources:

Interfaces:

Serial1/1/0 (ldp): xmit/recv

LDP Id: 10.0.0.1:0; no host route



Why does it show no host route?


gregwoodson Mon, 08/17/2009 - 11:38
User Badges:

Additionally:


top-7507#sh ip ospf mpls ldp int

Serial1/1/0

Process ID 23532, Area 0

LDP is configured through LDP autoconfig

LDP-IGP Synchronization : Not required

Holddown timer is disabled

Interface is up


It shows the LDP interface is up- but no routes or traffic is going thru.

shivlu jain Mon, 08/17/2009 - 22:13
User Badges:
  • Silver, 250 points or more

It means thats there is no route exists for your ldp identifier. May be you have not configured your loopback forcefully in the glocal for MPLS LDP router id. Please add the given commands in the both routers and clear the LDP neighborship.


mpls ldp router-id loopback0 force


After that run the ldp discovery command and you will find the positive results.


regards

shivlu jain

jon.harald.bovr... Mon, 08/17/2009 - 22:32
User Badges:

Hi


You might also need to configure network statment for loopback0 under router ospf.


To be sure loopbacks are in area 0.

gregwoodson Tue, 08/18/2009 - 07:00
User Badges:

Here's the logs on the last reboot after the last set of changes- you see that the LDP neighbor relationship AND the MPLS VPN both come up- but it's not passing routes or traffic- not sure why.


When I entered the "mpls ldp router-id loopback0 force " I got: "tag-switching tdp router-id Loopback0 force". Im also noticing that I dont see the "mpls ip" command anywhere in the config- even though it was put in (default?) I feel like there's just a little thing wrong here.


Suggestions? I have the latest config from one of the routers- they are the same on both sides.



*Aug 8 18:08:00 UTC: %PIM-5-DRCHG: VRF VRFB: DR change from neighbor 0.0.0.0 to 10.254.0.2 on interface Loopback1

*Aug 8 18:08:00 UTC: %PIM-5-DRCHG: VRF VRFA: DR change from neighbor 0.0.0.0 to 10.253.0.1 on interface Loopback2

*Aug 8 18:08:11 UTC: %LINK-3-UPDOWN: Interface Serial1/1/0, changed state to up

*Aug 8 18:08:12 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1/0, changed state to up

*Aug 8 18:08:19 UTC: %OSPF-5-ADJCHG: Process 23532, Nbr 10.0.0.2 on Serial1/1/0 from LOADING to FULL, Loading Done

*Aug 8 18:08:27 UTC: %LDP-5-NBRCHG: LDP Neighbor 10.255.0.2:0 (1) is UP

*Aug 8 18:08:34 UTC: %BGP-5-ADJCHANGE: neighbor 10.255.0.2 vpn vrf VRFA Up





Attachment: 
shivlu jain Tue, 08/18/2009 - 07:29
User Badges:
  • Silver, 250 points or more

please configure mpls ip and mpls label protocol ldp in the global mode. mpls ip will not shown not an issue. After that please paste the outputs of show mpls ldp discovery


regards

shivlu jain

gregwoodson Tue, 08/18/2009 - 07:31
User Badges:

Already done on both. Requested output:


Local LDP Identifier:

10.255.0.1:0

Discovery Sources:

Interfaces:

Serial1/1/0 (ldp): xmit/recv

LDP Id: 10.255.0.2:0

shivlu jain Tue, 08/18/2009 - 07:41
User Badges:
  • Silver, 250 points or more

the output is correct. Please let me know whats the problem you are facing now. Are you getting the proper ldp neighbors.


regards

shivlu jain

gregwoodson Tue, 08/18/2009 - 07:42
User Badges:

Yes- and as I stated previous- the LDP neighbor relationships and the VRF VPNs show to be up. However, they are not passing routes or traffic.

shivlu jain Tue, 08/18/2009 - 07:49
User Badges:
  • Silver, 250 points or more

the setup is like the given below


CE---Router-----Router-----CE


In the config files, I have not seen any MP-iBGP config. Please configure it.

After proper configure run the given command

show ip bgp vpnv4 all summary, you will see the number of routes coming from the specific neighbor.



regards

shivlu jain

gregwoodson Tue, 08/18/2009 - 07:54
User Badges:

What is the MP-iBGP config? I thought that BGP was used only for eBGP to the CE's and OSPF was used for the IGP.

shivlu jain Tue, 08/18/2009 - 08:03
User Badges:
  • Silver, 250 points or more

MP-iBGP is required to foward vrf routes over the service provider cloud. For that you require MP-iBGP. Please configure the given command and run the show ip bgp vpnv4 all summary


Bottom


router bgp 65500

bgp router-id 10.255.0.2

no bgp default ipv4-unicast

neighbor 10.255.0.1 remote-as 65500

neighbor 10.255.0.1 remote-as update-source loopback0

address-family vpnv4

neighbor RR_Routers send-community extended

neighbor 10.255.0.1 activate

neighbor 10.255.0.1 send-community both

address-family ipv4 vrf VRFA

redistribute connected

address-family ipv4 vrf VRFB

redistribute connected



top


router bgp 65500

bgp router-id 10.255.0.1

no bgp default ipv4-unicast

neighbor 10.255.0.2 remote-as 65500

neighbor 10.255.0.2 remote-as update-source loopback0

address-family vpnv4

neighbor RR_Routers send-community extended

neighbor 10.255.0.2 activate

neighbor 10.255.0.2 send-community both

address-family ipv4 vrf VRFA

redistribute connected

address-family ipv4 vrf VRFB

redistribute connected


regards

shivlu jain

gregwoodson Tue, 08/18/2009 - 08:14
User Badges:

If that's the case- then what is the use of the bgp ldp autoconfig? I want to remove BGP as part of the IGP fabric. Isnt this all supposed to be supported over OSPF?

shivlu jain Tue, 08/18/2009 - 08:29
User Badges:
  • Silver, 250 points or more

I donot know about that command. But ldp autoconfig for IGP is there which enable mpls on all interfaces automatically.


But you need to configure MP-iBGP for communication end to end.


regards

shivlu jain


netbeginner Wed, 08/19/2009 - 10:02
User Badges:

Hello Greg,


If ping reachability is there between both the router, the please check whether you enable "LDP" on both the routers glocally. If yes and other configs are also OK but still there is no traffic passing even after reachability between routers, then there may also be problem related to IoS of both end PE routers.





gregwoodson Thu, 08/20/2009 - 06:59
User Badges:

I guess this is where Im confused. I am trying to use OSPF LDP Autoconfig to move vrf traffic from router to router and eliminate BGP as an IGP. But Im seeing in the documents that BGP is required on all of the PE's for MP-BGP. What is the optimal way to set this up? Am I going to have to have all of the PE's peer across the network to share this VRF information?

netbeginner Thu, 08/20/2009 - 23:35
User Badges:

Hello Greg,


U can chck with this command "mpls ldp neighbor " to be exectute globally on far end PE, Hope for the best.



jon.harald.bovr... Fri, 08/21/2009 - 00:34
User Badges:

Add this BGP configuration to PE:

(replace xxx by proper AS)


bottom router:


router bgp xxx

no bgp default ipv4

nei iBGP peer-group

nei iBGP remote xxx

nei iBGP update loop 0

nei 10.255.0.1 peer iBGP


add vpnv4

nei 10.255.0.1 activate


add ipv4 vrf VRFA

red conn


add ip44 vrf VPNB

red conn


***************************************


top router:


router bgp xxx

no bgp default ipv4

nei iBGP peer-group

nei iBGP remote xxx

nei iBGP update loop 0

nei 10.255.0.2 peer iBGP


add vpnv4

nei 10.255.0.2 activate


add ipv4 vrf VRFA

red conn


add ipv4 vrf VPNB

red conn


Actions

This Discussion