Dial Backup Solution for Retail Store

Answered Question

I need to config a dial-in only solution for a 3800 with the following modules:


NM-1CE1T1-PRI

PVDM2-24DM


PPP dial-in works fine and gives out an address with the "ip local pool dialin" and "peer default ip address pool dialin" commands.


If I use SLIP, dynamic IP addressing won't work. That's not the issue though.


We currently have a 3com Total Control box that we are using today; which are being replaced with the 3800 routers.


I was told by the software folks that supply the POS software for our 2500 stores, that the dial backup connection does not use either SLIP or PPP. They state it uses a "serial ASYNC low speed connection to the 3COM box. The total control box, in turn converts to IP prior to sending the message to the server that processes transcations at corporate."


Does Cisco support this scenario? If so, what would the config look like?


Correct Answer by paolo bevilacqua about 7 years 11 months ago

You need exec under line. Can set modem to In, but that's a detail.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
paolo bevilacqua Mon, 08/17/2009 - 09:38
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Yes. Simply configure autommand with telnet to server ip address and port.


You can shorten the connection time with the appropriate AT commands for the modems. This is very important for slow speed POS.

paolo bevilacqua Mon, 08/17/2009 - 10:31
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Autocommand is a line config mode command.


You would remove the interface gr0 altogether.


You can check about commands that you

don't know in the reference manual.


Please remember to rate useful posts with the scrollbox below.

Still does not work. Here is my config. client connects fine, but the autocommand does not execute:


aaa new-model

!

!

aaa authentication login default group tacacs+ local

aaa authentication login noaut none

aaa authentication enable default group tacacs+ enable

aaa authorization exec default group tacacs+ none

aaa authorization commands 1 default group tacacs+ none

aaa authorization commands 15 default group tacacs+ none

aaa accounting exec default

action-type start-stop

group tacacs+

!

aaa accounting commands 1 default

action-type start-stop

group tacacs+

!

aaa accounting commands 15 default

action-type start-stop

group tacacs+

!

!

!

aaa session-id common

clock timezone EDT -5

clock summer-time EDT recurring

network-clock-participate slot 1

network-clock-select 1 T1 1/0


controller T1 1/0

framing ESF

linecode b8zs

cablelength short 110

ds0-group 0 timeslots 1-24 type e&m-fgb dtmf dnis


interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$

ip address 10.0.6.2 255.255.255.192

duplex full

speed 100


ip route 0.0.0.0 0.0.0.0 10.0.6.62


line 0/386 0/409

login authentication noaut

modem InOut

autocommand show ip interface brief

no exec

transport input all

transport output all

escape-character BREAK



Correct Answer
paolo bevilacqua Tue, 08/18/2009 - 07:11
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You need exec under line. Can set modem to In, but that's a detail.

paolo bevilacqua Tue, 08/18/2009 - 07:37
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Remember to configure the modems for fast connect, capping max speed to match POS, and use /stream in telnet command.


Thank you for the nice rating and good luck.



Actions

This Discussion