Need help with LinkSys SPA3102's

Unanswered Question

Let me start by saying that I'm a computer guy, not a phone guy......

We purchased two SPA-3102's for a client, for connecting his home office phone to his main office phone system.  I configured the two SPA's here at my office, based on recommendations from the VOIP reseller.  Here at the office, they worked perfectly.  I then shipped the units out and have them online at the client's office and home, but they don't work at all.  A call can't be completed to or from the home office.

Here is the set-up/details:

-Both SPA's are hooked up, via their internet ports, to the client's internal network

-I can PING both units and get to their admin web pages

-The home office and main office are linked by a firewall-based VPN tunnel, with all ports open in between

-The SPA at the home office has an analog phone plugged into it

-The SPA at the main office has an analog extension, off their phone sytem, plugged into it

-When picking up the home office phone you get a dial tone, but dialing an extension or phone number produces nothing

-When dialing the home office extension, from their main phone system, it just rings (but no ringing is shown on the home office end)

I haven't been able to find any diagnotics, logs, etc. that can help me determine where the issue is.  Would anyone have any ideas where I might go from here, other than giving up on these units?

Thanks very much,

Vishnu

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Hi Bill,

Sorry for the slow delay...I just had a chance to try out your suggestions.  The situation is that one 3102 is hooked up to an analog extension on their PBX at the main office.  The other 3102 is hooked up to an analog phone in the home office.  I enabled IP dialing and changed the dial plan, per your suggestion.  Now when the home office user tries to dial out (main office local extension OR outside line), the line just seems to go dead (no ringing, no busy tones, nothing....).  I've attached pertinent screenshots from both configs, for reference.  Let me know if any other pages would help....

Any other suggestions?

Thanks very much,

Vishnu

William Childs Wed, 09/09/2009 - 02:40

Vishnu,

I apologize for the delay in my response. I have setup your issue in our lab and have included the files on how I configured mine to work properly. I think it is how you are trying to get yours to work. The only thing you should change from mine to yours is the extension/ user-id. I think you use 1000 so just substitute 1000 for the 102 or 101 in the configuration.

Hi Bill,

Thanks for getting back to me.  Which of your config files is which (main office vs. home office)?  Also, I notice that when I'm trying to duplicate your config, some items don't match up due to my units being on an earlier version of firmware.  Should I upgrade the firmware?  I can physically get to the main office unit, but the home office is in a different state.... If I do upgrade the firmware, will the unit retain its settings so that I can get back into it remotely?

Otherwise, I notice that you don't specify a proxy on either of the Line 1 config's.  Does that not need to be set?

Thanks again,

Vishnu

William Childs Wed, 09/09/2009 - 23:31

Vishnu,

You can use either config for the office or home. The way I have it configured, you will dial the extension of the analog port on each device to make a "local" call from the office to the home (or vice versa). In my config, I have the pstn lines configured with ext. 101 and 102. If 101 is the home 3102, then dialing 102 will land you on the pstn port (so you can make an outbound call) of the office 3102. You should definitely upgrade your firmware and make sure you have someone at the home 3102 so they can set it to factory defaults after upgrading, that way you can start with a fresh configuration. The reason I don't specify a proxy is because I have the unit set not to register, and to make calls without registering. Pay special attention to each field under the Proxy and Registration field. Also make sure IP dialing is enabled.

Bill

Hi Bill,

I just wanted to make sure that we're on the same page, because something just doesn't seem right (unless it's just my misunderstanding of phone-systems).  Attached is a Visio diagram of the way we have it physically set up.  The following requirements need to be met:

  • Someone in main office can dial extension 120 and the phone in Washington will ring
  • Picking up the phone in Washington causes a connection to the phone system in Alaska, with dial-tone
    • User should be able to dial a "main office" internal extension in Alaska
    • User should be able to locally dial an Alaska phone number

I haven't had the opportunity to try the configs you sent me yet.  I wanted to make sure we're definitely on the same page first.  Based on the configuration needed, does that affect which config to use (of the one's you attached last post) on one unit or the other?

Thanks very much,

Vishnu

William Childs Wed, 10/14/2009 - 05:01

Vishnu,

I sincerely apologize about the length between my replies. I will take a look at it later today, and post an answer by tomorrow.

Many apologies,

Bill

William Childs Thu, 10/15/2009 - 03:23

This is the dialplan for line 1 of the Washington SPA3102.

xx.<:@10.0.1.15:5061> ( The xx. should be replaced by as many x's as there will be digits dialed)

For Example- xxxx would be needed for 4 digit dialing, xxx would be for 3 digit dialing

The line should be set NOT to register and also be set to make/receive calls without registration. It should also be setup for ip dialing without Auto PSTN fallback enabled.


In the Alaska office, the dialplan of the pstn line will be similar but many other things will need to be implemented for this to work. First, make sure on the PSTN Line tab the Line Enable: is yes, Register: is  no, Make Call Without Reg: is yes, Ans Call Without Reg: is yes, and you do not need a username, password, or proxy server.

Second,under the Dial Plans section we will modify Dial Plan 1: to look like this:

S0<:@10.0.1.5:5060>

Next, under VoIP-To-PSTN Gateway Setup, make sure the VoIP-To-PSTN Gateway Enable: yes, One Stage Dialing: yes, Line 1 VoIP Caller DP: 1, VoIP Caller Default DP: 2. The default dial plan 2 is very important because we dont want the Washington caller to try to dial himself.

At this point we will need to modify the PSTN-To-VoIP Gateway Setup. Set the PSTN Ring Thru Line 1: to no, and the Off Hook While Calling VoIP: to yes. This way no one else can call while the line is busy.

Lastly, set the PSTN Answer Delay: to 3. If you don't, you will have a long pause that may confuse the caller. This can be set lower but I recommend 3.

I have attached the working setup that I used. If you make your configuration match mine, then your situation should function without a problem. The only thing you would need to do, is change the ip addresses I have to your own.

I hope this helps.

Bill

P.S. I missed the part where the Alaska user needs to be able to dial locally as well. Just enable PSTN fallback on the Alaska user's ATA and disable VoIP-To-PSTN on the same ATA. The dialplan will also need to be modified. It should look like this instead:

<9:>S0<:@10.0.1.15:5061>| (insert local dialing rules here)

This will mean that the user will add 9 to any company extension, and when the user picks up, they will automatically be dialing locally.

Attachment: 

Hi Bill,

I'm still having issues with the units/configs.  I updated the firmware on both units and re-configured them, but when the remote user tries to dial either an extension or an outside line, he gets a fast busy signal.  We also can't call him from the main office.  I was a bit confused, when re-configuring them as you recommended, because you attached the configs and also mentioned some specific items that needed to be set a certain way that conflicted with what you attached.  So, I'm still not 100% confident that I have the configs the way you have recommended.

I've attached the current running configs.  Please let me know if I've missed/jumbled something.

Thanks very much,

Vishnu

William Childs Sat, 11/14/2009 - 05:26

Vishnu,

If the previous configuration still did not work for you, you may be better off giving the SBSC a call. Their number is 866-606-1866.

Bill

William Childs Thu, 08/20/2009 - 02:32

Vishnu,

According to the first line of your post, it sounds like you want to have the home office's phone calls to be placed and received through the main office phone system. What kind of phone system is at the office? IP based or analog? Do you want the phones attached to each 3102 to make calls independently of each other, or is this just to link the home office to the main office? If you have an IP based system at the main office, then just use an ip phone (or SPA2102) at the home office and make it register to the main office pbx. If the main office system is a traditional pbx (all analog), then you need to enable IP dialing and configure your line 1 dial plan to look a little like this,

(s0<:@ip_of_3102:5061>)

each line should not be registered and should give you a dial tone when the analog phone at each end is picked up. Hope this helps and good luck.

Bill

P.S.- You may want to check out this thread if my instructions were not very clear.

https://www.myciscocommunity.com/thread/4235?start=0&tstart=0

Actions

This Discussion