RTMT on Ubuntu

Unanswered Question
Aug 17th, 2009

Has anyone tried installing RTMT on linux?

I have the Sun Java 1.6 JRE installed and the path seems to be set correctly. Everytime I try installing the BIN file I get the following output

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

[email protected]:~/Documents$sudo ./CcmServRtmtPlugin.bin

Preparing to install...

Extracting the JRE from the installer archive...

Unpacking the JRE...

Extracting the installation resources from the installer archive...

Configuring the installer for this system's environment...

Launching installer...

Exception in thread "main" java.lang.NoClassDefFoundError: com/zerog/lax/LAX

Caused by: java.lang.ClassNotFoundException: com.zerog.lax.LAX

at java.net.URLClassLoader$1.run(URLClassLoader.java:200)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:188)

at java.lang.ClassLoader.loadClass(ClassLoader.java:307)

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

at java.lang.ClassLoader.loadClass(ClassLoader.java:252)

at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)

Could not find the main class: com.zerog.lax.LAX. Program will exit.

[email protected]:~/Documents$ java -version

java version "1.6.0_14"

Java(TM) SE Runtime Environment (build 1.6.0_14-b08)

Java HotSpot(TM) 64-Bit Server VM (build 14.0-b16, mixed mode)

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Please help!!!!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
joe.bennett Mon, 08/17/2009 - 22:13

It works fine for me but I have to turn off Compiz to get anything on screen. Go to System->Preferences->appearance and on the visual effects tab choose none. That works for me but isn't what I'd choose to do.

Akin Utku Mon, 08/17/2009 - 22:16

Dude, can you do me a huge favour and paste the output to the following on your system?

echo $PATH

java -version

I think it has something to do with my path or the version of java

joe.bennett Mon, 08/17/2009 - 22:59

blah:~$ echo $PATH

/home/blah/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games

blah:~$ java -version

java version "1.6.0_14"

Java(TM) SE Runtime Environment (build 1.6.0_14-b08)

Java HotSpot(TM) Server VM (build 14.0-b16, mixed mode)

Running Jaunty upgraded from at least Intrepid (if not Hardy).

Running 32bit not 64bit though.

Akin Utku Tue, 08/18/2009 - 19:03

Yea, I tried a 32 Kernel and it works fine. The BIN file has its own JRE included and I think that doesn't work on the 64 bit kernel. I'll see if I can hack it so that it uses the SUN 1.6 64bit JRE. This may take a while though :) Oh well, 32 bit it is. Thanks for the help!

Actions

This Discussion