Help! New switches lose connectivity after image upgrade.

Unanswered Question
Aug 17th, 2009

I just purchased four C3750E switches (3750E-48-PD-SF)

They all came with the following image:


UNIVERSAL W/O CRYPTO WITH WEB BASED DEV MGR (c3750e-universal-tar.122-35.SE5.tar)

I set up the 1st switch, configured it via console, connected its ethernet management port to my "normal switch" and all was well.

Then I attempted to upgrade to the latest revision - 12.2.50-SE3(ED) via the web-based management.

On the first switch, I tried the following image:

UNIVERSAL WITH WEB BASE DEV MGR (c3750e-universalk9-tar.122-50.SE3.tar )

The upgrade itself was trouble-free, but when I rebooted the switch, I could not access it via the network.

The management LAN connection bounces up and down on the switch it's connected to.

I see nothing on the console indicating that the new switch thinks there's a problem.

Then I tried the same routine on the 2nd switch, only this time I used the non-crypto version of the file - c3750e-universal-tar.122-50.SE3.tar

Same result: the upgrade goes fine, but post-reboot, the connection just bounces up and down.

Am I missing something obvious here?

I've never had this problem before.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Lucien Avramov Mon, 08/17/2009 - 23:29

Interesting, what is the config register on them (you can see it on the show ver)?

Have you saved the running-config before rebooting?

What do you see on the console when it keeps on restarting?

GRANT GATHAGAN Tue, 08/18/2009 - 05:58


Thanks for the response.

I'll check the register when I get in to work.

Yes, the configuration is saved.

The switch retains the configuration.

Maybe it's not clear from my post; the switch does not keep restarting.

When you are looking at the CLI of the switch, it shows nothing, but when you look at the CLI of the switch that the 3750 is connected to, *that* is where you see the port bouncing with a link-flap error message.

You also see the link light on that 2nd switch light up and then go dark every second or so.

thinakraj Tue, 08/18/2009 - 02:42

hi .. can you tel me after restarting which mode your are getting in the CLI?

thinakraj Tue, 08/18/2009 - 03:23

hi can you try this IOS ....



Release Date: 28/Jul/2009

Size: 11983.83 KB (12271438 bytes)

Minimum Memory: DRAM:256 MB Flash:64 MB



Release Date: 28/Jul/2009

Size: 14880.00 KB (15237120 bytes)

Minimum Memory: DRAM:256 MB Flash:64 MB



Release Date: 28/Jul/2009

Size: 12813.86 KB (13121383 bytes)

Minimum Memory: DRAM:256 MB Flash:64 MB



Release Date: 28/Jul/2009

Size: 15710.00 KB (16087040 bytes)

Minimum Memory: DRAM:256 MB Flash:64 MB

GRANT GATHAGAN Tue, 08/18/2009 - 05:59


Thank you also for your response.

I'm pretty sure the switch is in non-priveleged mode when rebooted, since I recall having to enter the secret to get in to privileged mode.

I'll check on that when I return to work.

I'm not sure I understand your 2nd question.

As I stated in the original post, I have tried both the Universal w/o crypto and the universal with crypto versions of the IOS you listed - 12.2.50(SE3).

What is it that you are asking me to try?

Lucien Avramov Tue, 08/18/2009 - 06:52

Ok so you have a link that is bouncing, is that just an ethernet connection? It could also be that a cable went wrong, have you tried to replace it?

What does the console says about this event?

When you say link go up and down on the light, is it the ethernet port LED?

The image you are using is supposedly supported according to the release notes.

GRANT GATHAGAN Tue, 08/18/2009 - 18:30


The cable is fine, as the problem only existed once the IOS was upgraded. When I put the same cable on a non-upgraded switch it works fine.

The console on the 3750 says nothing, the console on the switch I'm attaching to gives me the link-flap error.

At any rate I got it working.

The short answer is:

I was using the LAN management port to connect the 3750 to my network.

The original IOS didn't care, but the newer IOS does.

Once I used one of the gigabit ports on the front panel, I had no problems.

Not sure if that is working as designed, but it *is* working.

Thanks to all for the input.


This Discussion