Cisco LMS and GSS 4492 Appliance

Answered Question
Aug 18th, 2009
User Badges:

Hello,


I have added the GSS to DCR and the verification report shows the SNMP, ssh, enable by ssh is all Ok.


But on running Sync Archive via RME, I get the following error


Protocol ==> Unknown / Not Applicable

Selected Procotol with order --> SSH, TFTP

Execution Result:

CM0062 Polling GSS for changes to configuration

CM00 Polling not supported on PRIMARY STARTUP config, defaulting to fetch.

CM00 Polling not supported on PRIMARY RUNNING config, defaulting to fetch.


--


And the Archive Mgmt jobs shows as 'Partially Successful'.


What does partially successful mean ?


Thanks


Correct Answer by Joe Clarke about 7 years 11 months ago

You would need SAS or Software and Support to open a case on LMS. The workaround is to leave:


terminal-length 0


In your global config at all times.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Tue, 08/18/2009 - 03:46
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

RME does not know how to do configuration polling for this device, therefore it will always attempt to fetch the config, then look to see if anything has changed. Therefore, what you see here about polling being unsupported is expected.


When running the sync archive job, do not check the Poll box when syncing the GSS devices, and the job should complete successfully. However, even if the box is checked, since RME will default to fetch, the config should still be archived properly.

tech_trac Tue, 08/18/2009 - 04:33
User Badges:

Hello,


I unchecked the polling, still the error appears but this time it is different.


Protocol==> Unknown/Not Applicable

Selected Protocols with order ==> SSH

Execution Result:

STARTUP

CM0151 PRIMARY STARTUP Config fetch failed for GSS1 Cause: fig from device:java.net.SocketTimeoutException:Read timed out Action: Check if protocol is supported by device and required device package is installed. Check device credentials. Increase timeout value, if required.


I am able to do ssh into the GSS device from Cisco Works Server and the device cred. verification report is also successful.


Regards.


Joe Clarke Tue, 08/18/2009 - 04:40
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What version of RME is this?

Joe Clarke Tue, 08/18/2009 - 04:45
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Also, what version of code is running on the GSS?

Joe Clarke Tue, 08/18/2009 - 10:57
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Exactly what output and prompts do you see when you manually SSH to the GSS, and do the following:


en?

enable

show glsb-config

show startup


tech_trac Tue, 08/18/2009 - 11:57
User Badges:

Right after ssh -> I get the below


login as: admin

[email protected]'s password:

Last login: Tue Aug 18 16:28:30 2009 from a.b.c.d

GSSA>en

Password:

GSSA#sh startup-config


GSS configuration [Saved: Thu Jul 16 20:40:18 GST 2009]

.

.

.

.



GSSA#sh gslb-config


region "Central USA" comments "Central USA Region"

region "Eastern USA" comments "Eastern USA Region"

region "Western USA" comments "Western USA Region"


owner System


gss-device GSSA activate

gss-device GSSB activate



source-address-list Anywhere owner System

ip address 0.0.0.0 0.0.0.0

.

.

.

.

.

.



Joe Clarke Tue, 08/18/2009 - 12:07
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I need you to run the commands exactly how I specified them as that is what RME will do. I also need to see any prompts you get while displaying the startup config and gslb-config.

Joe Clarke Tue, 08/18/2009 - 19:18
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Something else that may help here is to enable ArchiveMgmt Service debugging under RME > Admin > System Preferences > Application Loglevel Settings, re-run the Sync Archive job, then post the dcmaservice.log. The GSS code has some considerable debugging built-in, so the timeout problem should be visible.

Joe Clarke Wed, 08/19/2009 - 22:31
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You did not enable debugging prior to getting this log. You need to first enable debugging, then run a new Sync Archive job, then post the new log.

tech_trac Wed, 08/19/2009 - 22:38
User Badges:

When I go to 'Applicaton Log Level Settings', then select ArchiveMgmt from the Application drop down. Both Archive Service and Archive Client are set to debug. Is that sufficient.


Also, when I try to change the Application to All and select Debug and click Apply I get the following message


RMELOG0003: Error while reloading log level for the service - Archive Service.The service might need to be restarted for the settings to take effect.

RMELOG0001: Successfully updated the Log levels.


Joe Clarke Wed, 08/19/2009 - 22:43
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

ArchiveMgmt Service is sufficient, assuming the setting was applied. You will then need to re-run the job so that debugging is written to the log.

tech_trac Wed, 08/19/2009 - 23:18
User Badges:

Hello,


Please find the log attached. I didn't find much difference in the log.


I set the ArchiveMgmt Service to debug, and submitted a new sync archive job for GSS device.





Attachment: 
Joe Clarke Thu, 08/20/2009 - 06:38
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

No, there is still no debugging here. Try restarting ConfigMgmtServer, and try again:


pdterm ConfigMgmtServer

pdexec ConfigMgmtServer

tech_trac Thu, 08/20/2009 - 10:38
User Badges:


Please let know how to restart ConfigMgmtServer.


Is pdterm and pdexec a CLI command.

Joe Clarke Thu, 08/20/2009 - 10:44
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Yes. These should be run from a DOS prompt on the server.

tech_trac Sun, 08/23/2009 - 01:48
User Badges:

Hello,


I have attached the detailed log.


I have removed the actual configuration blocks from the log. Hope it doesn't prevent studying the problem.


Thanks.



Attachment: 
Joe Clarke Sun, 08/23/2009 - 08:27
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

There is a bug in the GSS platform code in RME in that it doesn't properly disable the pager. I can build a patch for you to try. If you open a TAC service request, and have your engineer contact me directly, I will send them the patch.

tech_trac Sun, 08/23/2009 - 11:42
User Badges:

Hello,


We have Cisco Shared Support with a Cisco Gold Partner. But we don't have SmartNet. Supposedly, we may not be able to raise a TAC case due to absence of SmartNet.


Is there any workaround for this bug ?


Thanks.

Correct Answer
Joe Clarke Sun, 08/23/2009 - 11:45
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You would need SAS or Software and Support to open a case on LMS. The workaround is to leave:


terminal-length 0


In your global config at all times.

Actions

This Discussion