VXML Server Service Terminates unexpectedly

Unanswered Question
Aug 18th, 2009

I'm having an issue with a CVP 7.02 install where the VXML server service keeps terminating on its own. The Event Viewer on the server simply states the VXML Server service has terminated unexpectedly and this has happened nn times. I have looked at all the logs I know of (..\Tomcat\logs, \Cisco\CVP\logs, \Cisco\CVP\VXMLServer\logs, and the app log paths themselves) but there is no indication of what is going on to cause the service to crash. The intrestiong thing is somtimes it crashs even when no calls are going through the system so I doubt that it is load related.

I do have a TAC case open on this, but i am just curious to see if anyone else has run into this before.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)

Yes, we have seen this - but don't know why it stops.

Try the following:

1. Stop the service.

2. Make it manual

3. Open a command window in Tomcat\bin

4. Run a little batch file that says:

set JRE_HOME=C:\Cisco\CVP\jre

set BASEDIR=C:\Cisco\CVP\VXMLServer\Tomcat


5. Run setclasspath.bat

6. Call startup.bat

I bet that Tomcat will start and continue to run forever.

The problem is not with Tomcat itself, but when it runs as a service. If the service is configured to restart, then it will do so.

I don't think it's crashing - it's some weird service thing.



jasonprescott Mon, 10/12/2009 - 20:26

Sorry I never re-posted on this. The case I had open lingered out there for a while.

One of the troubleshooting steps we tried was using jconsole to monitor the if the garbage collector service was running properly and freeing up memory.

In order to set up ports on the CVP server for jconsole to work from a remote server a few registry entries are needed to open up the ports:

. In regedit go to HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Procrun

2.0\VXMLServer\Parameters\Java. In Options, add the following.





So after adding those entries, (which should have nothing to do with keeping the VXML server stable) the VXML server service stayed up.

I put that in about a month ago, and everything has been stable since.

Chuck Smith Fri, 04/09/2010 - 08:15

This is why I love these forums! Thanks Jason your post saved me a lot of headache.

Adding the following to the registery worked for me.

In order to set up ports on the CVP server for jconsole to work from a  remote server a few registry entries are needed to open up the ports:

.   In regedit go to HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software  Foundation\Procrun

2.0\VXMLServer\Parameters\Java.   In Options,  add the following.





I have a similar solution for the Java Options.

This problem has come up for us recently on a different set of servers.

We are migrating a customer's CVP from CVP4 to CVP7 using tech refresh - so new servers - and the VXML Server (as a service) always crashes after 46 mins on both boxes. We have other CVP7s installed with no issues on similar hardware.

When it runs from a command window as I described above, stays up forever.

We have ES22 installed (that updates the JRE and fixes a stability problem with the service - similar to the JRE post I made above).

In the course of TAC trying to figure out the problem, they asked me to change the JRE options in the registry, so that if when the probelm reoccurred we would get a heapdump file in the HeapDumpPath location.

HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Procrun 2.0\VXMLServer\Parameters\Java\Options

Once this was done, it simply would not crash. If I take this out, it will only last 46 mins.

It writes the hs_err_pidXXXX.log files in WINDOWS\system32 and they say

#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x002d002d, pid=8052, tid=7436

Current thread (0x4a2cf560):  JavaThread "Cisco Unified CVP VXML Server: Administration Connector" daemon

They always say the current thread is in the Admin Connector daemon, which agrees with the fact that it runs fine from the cmd line, but not as a service. The DE has no clue as to what's wrong and says something may have been corrupted during the install. I have a hard time believing this, as the problem is exactly the same on both machines.

Isn't it amazing that the change to the Java Options makes it stay up.



eric.neoh Wed, 09/15/2010 - 01:28

Hi, jasonprescott.

We also encountered the similar problem. Just found your post in the forum, we would want to try the "workaround" as mentioned in your post. Do we need to reboot the CVP server after adding in the 4 registry entries? Any other steps that we need to take care of?

Thanks & Regards,


This Discussion