Multicast cloning

Unanswered Question
Aug 18th, 2009

Sorry if there's a thread on this already...I tried looking. I have an imaging server set up on its own VLAN using a 2950 switch but I cannot get the images to multicast to the clients. I also have trouble with DHCP requests going through on some of the ports. Let me know what config info you need. I'd appreciate the help as I'm new to IT in general and managed switching is voodoo magic to me.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Mohamed Sobair Tue, 08/18/2009 - 12:05


Could you let us know How is your current Network design?

How are the Multicast server and the Multicast clients connected?


jmviens01 Tue, 08/18/2009 - 12:14

I have the multicast server connected to port 1 of the switch and the clients are connected to the remaining ports. All ports are set up in a single VLAN (Vlan 1).

Jon Marshall Tue, 08/18/2009 - 12:38


Just to clarify - is the server in the same vlan as the clients as you originally said the server was set up in it's own vlan.

If the server is in a different vlan where are the L3 vlan interfaces for these vlans ?


jmviens01 Tue, 08/18/2009 - 13:25

Sorry...the vlan consists of the server, switch and clients.

Mohamed Sobair Tue, 08/18/2009 - 12:44


You dont require any additional config.

The Switch by default forwards Multicast and Broadcast traffic out its all port except the port the Multicast was recieved on.

To Optimize your multicast traffic, please issue the command (ip igmp snooping) in the global config mode.

with this command, Only ports that Joins the Multicast Group defined by the multicast application is going to recieve multicast from the server and the Switch will create a special multicast table for it.



Jon Marshall Tue, 08/18/2009 - 12:48


"To Optimize your multicast traffic, please issue the command (ip igmp snooping) in the global config mode."

Won't make any difference without something to issue the IGMP queries. Looks like the IGMP snooping querier function may be supported though -


Edison Ortiz Tue, 08/18/2009 - 12:48

By default all switchports have spanning-tree portfast disabled which causes workstations to fail on obtaining an IP address on time from the DHCP.

It's recommended to configure workstation attached switchports with the command:

spanning-tree portfast

More information can be found on this document:




Please rate useful posts

jmviens01 Wed, 08/19/2009 - 05:35

Running the command sh conf provides the following (all ports are set up the same way):

ip igmp snooping Vlan 1 mrouter interface Fa0/x

interface FastEthernet0/x

switchport mode access

spanning-tree portfast

interface Vlan 1

[ip/netmask for vlan]

no ip route-cache

Does any of that help?


This Discussion