Caller-id is not showing under voice-port

Unanswered Question
Aug 18th, 2009

I am having problems with getting caller id to show up on pstn incomming calls. The IOS version is c1700-sv8y-mz.122-15.zj3.bin. I have researched caller-id and it requires that "caller-id enable" be set under the voice-port, however the command is not there. I also tried to set remote-party-id under sip-ua, but when I do a show run, I do not see the command. Is my ios not supporting caller id or might it be the wvic-1mft-t1 card that is not supporting the caller id. Any help is appreciated!!!! Part of the config is below:

controller T1 0/0

framing esf

linecode b8zs

pri-group timeslots 1-24

interface Serial0/0:23

no ip address

no logging event link-status

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

voice-port 0/0:23

no vad

no comfort-noise

dial-peer voice 7 pots

preference 1

destination-pattern .


port 0/0:23

forward-digits 10

dial-peer voice 600 voip

description Match All

preference 1

destination-pattern .

session protocol sipv2

session target

session transport udp

dtmf-relay rtp-nte

codec g711ulaw

no vad

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
daljeetsingh1_2 Wed, 08/19/2009 - 02:04

I doubt it when you say you have seen caller-id command for voice port in some document. What you might have seen under voice ports "caller-id enable" is for analog configuration not the T1 voice port, please crosscheck, thats the reason you are not seeing it under T1 voice port.

And as far as your configuration is concerned it looks fine. could u send me complete show run? i believe your IOS is also old, for 1760-V Modular router "12.4.15T9(MD)" is the IOS i see is the latest. (i am assuming this router is only used for PSTN termination)

Please check what T train IOS your router suits the best and upgrade it.

Let me know!!


This Discussion