Can not add users to Unity 7.02

Unanswered Question
Aug 19th, 2009

I have a working system that now is not letting me add users. I am getting this error when I try to add them.

"An Unrecognized error 0x80070057 has occurred:

E_INVALIDARG

The new subscriber was not successfully added"

I re-ran my permission wizard but that did not help.

Thanks

Ken

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jaime Valencia Wed, 08/19/2009 - 10:28

The issue indeed mut be permissions, make sure u use the right account for PW:

Please run the PW with an account that has the following:

# Log on to the Cisco Unity server by using an account that:

* Is a member of the Domain Admins group in the domain in which the Cisco Unity server is being installed, or that has permissions equivalent to the default permissions for the Domain Admins group.

* Is either an Exchange Full Administrator or a member of the Domain Admins group in the domain that contains all of the domains from which you want to import Cisco Unity subscribers.

Caution! If you try to run the Permissions wizard using an account that has less than the default permissions for a Domain Admin, the Permissions wizard may not be able to grant all of the permissions required by the installation account and the services accounts. If the Permissions wizard cannot grant all of the required permissions, either the Cisco Unity installation will fail, or Cisco Unity will not run properly after it has been installed.

Also make sure you have delegated control in the Exchange Manager to the necessary accounts (PW provides all the info after you run it)

HTH

java

if this helps, please rate

kgroves42 Wed, 08/19/2009 - 10:44

Thanks for the reply. But I have run the Permission wizard with an account that is a domain admin where the unity and users are located. It is also a Full Exchange Administrator.

I have delegated control to the installation account and Directory service account in exchange.

The odd thing is if I search for the user I added in Unity they show up as a subsciber, however when I go to click on them to get into their properties, I get "page can not be displayed" in my web browser. The user is not listed in Global subscriber manager, however if I go to the subscriber table in SQL they are listed. So I removed the row in SQL, ran dbwalker to clean up any references to it. But then I tried to add it again and I get the same error.

ahopkins Thu, 08/20/2009 - 05:13

I just wanted to jump in here to support "kgroves" findings. I'm currently performing an installation of Unity 7.0.2 and am experiencing the exact same problem and symptoms when trying to import a subscriber as described by "kgroves". I've also run PW and verified all account rights. The problem seems to be identical.

Jaime Valencia Thu, 08/20/2009 - 10:36

Are there any errors in the app log for this??

What's the exchange/AD version?

HTH

java

if this helps, please rate

kgroves42 Fri, 08/21/2009 - 10:54

Ok this is fixed. What seemed to do it was running the Message Store Config Wizard again. We also did a force reconnect in the DC/GC Settings Tool. Not sure what changed to cause us to do that but that is what seemed to fix it.

ahopkins Mon, 08/24/2009 - 09:56

I'm scheduled to be back on-site Wednesday with my customer and will take a look at running the wizard again to see if this fixes my issue as well. Thanks for posting back your results

Actions

This Discussion