Communication issue and conclusion from "Input errors, CRC"

Answered Question
Aug 19th, 2009
User Badges:

Folks, I have two switches:

4507 (port f3/2)---- 3750 (port f0/23)


All of sudden I see intefaces on 4507 f3/2 up/down. I go to 4507 and I see that the switchport f3/2 has some input errors and CRC errors. Then I see on 3750 switchport fa0/23 got way more errors. Also, output from show tech on 4507 switch showed message " Aug 19 10:37:22.549: %DTP-5-NONTRUNKPORTON: STANDBY:Port Fa3/2 has become non-trunk

Aug 19 10:41:57.180: %DTP-5-TRUNKPORTON: Port Fa3/2 has become dot1q trunk...". I imagine that such status that the port was a non-trunk was due to a bad communication (bad cable or bad switchport), correct?


Also, do you agree that based on the fact that I have way more input errors and CRC errors on switchport fa0/23 on the 3750 I can conclude that if it is a faulty switchport that would be likely be on the 3750? I will try to replace the cables and see if the problem goes away. Let me know if you have other approach in mind based on the data provided.


3750#show int

(...)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

18682 packets input, 9509495 bytes, 0 no buffer

Received 18582 broadcasts (17576 multicast)

0 runts, 0 giants, 0 throttles

115699 input errors, 102042 CRC, 13657 frame, 0 overrun, 0 ignored

0 watchdog, 17576 multicast, 0 pause input

0 input packets with dribble condition detected


3750#show int f0/23 switchport

Name: Fa0/23

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: down

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: 2

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Appliance trust: none








4507#show int f3/2

FastEthernet3/2 is up, line protocol is down (notconnect)

(...)

Received 346732480 broadcasts (345361439 multicasts)

32 runts, 0 giants, 0 throttles

71 input errors, 39 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

20225802 packets output, 1643442465 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

4507#show int f3/2 switchport

Name: Fa3/2

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: down

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk associations: none

Administrative private-vlan trunk mappings: none

Operational private-vlan: none

Trunking VLANs Enabled: 2

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL


Correct Answer by Lucien Avramov about 7 years 8 months ago

Your approach sounds overall correct.


Here is a useful doc for the CRC errors:


http://www.ciscotaccc.com/kaidara-advisor/lanswitching/showcase?case=K19375172

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
glen.grant Wed, 08/19/2009 - 16:12
User Badges:
  • Purple, 4500 points or more

Verify port settings on each match , if one end is set as auto for speed and duplex then the other end "must" be set as auto also. Sounds like a speed/duplex mismtach.

news2010a Wed, 08/19/2009 - 16:36
User Badges:

It turned out it was a cable miswired. Once I asked to rebuild and repatch cable, things worked.

Lucien Avramov Wed, 08/19/2009 - 18:58
User Badges:
  • Red, 2250 points or more

Great.

That is usually most of the times the issue. If no one touches the duplex settings, it wont happen.


Glad you resolved it.


Actions

This Discussion