Password Recovery Wierdness

Unanswered Question
Aug 19th, 2009


I am trying to do a password recovery on a 2960g. I follow the documentaion that says to hold down the mode button until I see:

The system has been interrupted prior to initializing the

flash filesystem. The following commands will initialize

the flash filesystem, and finish loading the operating

system software:



So I issue the flash_init command and if I follow the documentaion I should do the load_helper command which comes back with an error:

Unknown cmd: load_helper

It's like I dont have this command at my disposel. What can I do now??

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
pener1963 Wed, 08/19/2009 - 17:09

You are right but the documentation is not. It stated I needed to do a load_helper and I tried. But what the heck ... I am good now.

Many thanks

Peter Paluch Thu, 08/20/2009 - 06:24


In my experience, the "load_helper" command is necessary on certain types of switches that use a multistage process of booting - first a helper image is loaded. This helper image is not a full IOS but it is smarter and has more features than the bootloader code in the ROM. This helper image in turn loads the final full IOS image.

On 2950/2960, 3550/3560 Catalyst switches, the helper image is actually not used at all, and this command does nothing - but the command was indeed there. However, if it is not available anymore on your switch then perhaps your ROM bootloader is newer and the unnecessary "load_helper" command has been removed, just the documentation was not updated.

The bottom line is, you can skip it which you obviously did :)

Best regards,


johnlloyd_13 Thu, 08/15/2013 - 09:24

hello peter,

was doing a password recovery on a 3560 switch awhile ago. didn't know we could skip the load_helper command.

obviously, i got stuck with the old cisco doc when doing a password recovery.

do you have a deeper technical overview or idea why this command isn't necessary, perhaps in newer switch platforms?

jawad-mukhtar Thu, 08/15/2013 - 12:03

Please dont copy and paste what i think so it will not work in rommon mode.

type command manually through keyboard



Peter Paluch Thu, 08/15/2013 - 17:04

Hi John,

To be honest, I wish a SME from the LAN Switching BU was around to answer this question. I tried to find any example of a scenario where the load_helper command actually had an effect but I was not successful. The older documentation only says that this command can be used to load an additional image that patches or extends the functionality of the boot loader. I was not able to find any working example, though. Sorry about that.

Best regards,


johnlloyd_13 Thu, 08/15/2013 - 17:16

Thanks for your feedback Peter! +5 sir!

I thought my Google skills failed me last night.

I hope Cisco folks will come up with an updated doc very soon for everyone's benefit.

Sent from Cisco Technical Support iPhone App


This Discussion