HELP router has lost ir eigrp neighbor relationship!

Unanswered Question
Aug 20th, 2009

My router has lost its eigrp neighbor relationship so has lost all its routing information even though I can ping the neighbor address from the router. All interfaces are up.

I have tried restarting the router.

Its neighbor has the following logs

Aug 20 12:22:31.855: %DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 10.128.34.9 (Vlan

8) is down: retry limit exceeded

Aug 20 12:22:32.947: %DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 10.128.34.9 (Vlan

8) is up: new adjacency

I have tried the clear ip eigrp neighbor 10.128.34.9 from the routers neighbor.

Any help much appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
darrenriley5 Thu, 08/20/2009 - 04:54

Yes its happening alot. No changes have been made although when I logged on to the router debugging was enabled which i have now turned off.

Jon Marshall Thu, 08/20/2009 - 05:01

Darren

Any debugging can put an overhead on the router and the more general the more overhead. The router may have been so busy handling the debugging it could not process the EIGRP hellos in time and so the EIGRP adjacency went down.

Have you lost the adjacency since you turned off debugging ?

Jon

darrenriley5 Thu, 08/20/2009 - 05:04

No its still happening. The logs stamps 1 hour behind so I thought it had stopped initially. The router is connected to a switch stack. The switch stack has a connection to each core switch. the core switch have a vlan which is the routers eigrp neighbor

Jon Marshall Thu, 08/20/2009 - 05:08

Darren

Can you check all your devices to make sure none of them have debugging turned on. Then go through that document to see if any of it applies to your scenario.

EIGRP neighbors lose adjacency when they miss a certain number of hello's. So you need to check both your core devices, the router itself and the switch stack to make sure you have no bottlenecks anywhere.

Jon

darrenriley5 Thu, 08/20/2009 - 05:10

Our core switches show the router in its list of eigrp neighbors.

The router doesn't have any eigrp neighbors.

ktwaddell Thu, 08/20/2009 - 06:15

Darren

What about the path it takes, have you tested it?

Send 5000 pings with a datagram of 1500 and what are the results?

Jon Marshall Thu, 08/20/2009 - 08:48

Kev

Long time no speak.

Quiet day at NR then ?.

I'm assuming your'e still at NR ?

Jon

Peter Paluch Thu, 08/20/2009 - 06:37

Darren,

Please do the ping test as Kevin suggested. Also, allow me a couple of questions:

1.) Did this problem come just out-of-blue, or were there any changes implemented in the network, no matter how insignificant?

2.) How many EIGRP neighbors should the router 10.128.34.9 have? Do all these neighbors report flapping adjacencies or only some of them?

3.) Is there any EIGRP authentication in place?

4.) Can you please post the configuration of the EIGRP process and the Vlan8 interfaces of both the router 10.128.34.9 and its neighbor?

Best regards,

Peter

ronbuchalski Thu, 08/20/2009 - 11:37

Does it try resetting the EIGRP neighbor every 120 seconds or so? If so, then the problem you may be experiencing is related to a multicast issue between the router and its' neighbor. EIGRP uses multicast packets to communicate with neighbors.

To confirm whether it is a multicast issue that is affecting your peering, try defining your EIGRP neighbors explicitly on the two peers (using the 'neighbor' command within router eigrp config). By explicitly defining your neighbors, they will communicate using unicast packets, thus eliminating multicast problems as a potential cause.

I had this problem with EIGRP peering over a Metro Ethernet connection. The provider later confirmed that a bug in their ME equipment was affecting multicast communication.

Hope this helps.

Ron Buchalski

jimmysands73_2 Thu, 08/20/2009 - 15:27

Darren,

>>I logged on to the router debugging was enabled which i have now turned off.

On top of what everyone else has said, when you noticed someone else had debugging on...what it for eigrp? Possibly someone else was ts'g the problem already and you could save time depending on the size of your org by asking around. If not, then if they had debugging on then maybe they were troubleshooting a differenet problem and during the rucus, did something to cause your EIGRP to have fits. You probably already thought about this, but figure I would throw it in.

Cheers and good luck,

Jimmy

Actions

This Discussion