ping issue on 1721

Answered Question
Aug 20th, 2009

Good afternoon all. I have a ping issue regarding a pc and a 1721 router fa0 connected to a 2512 switch. PC will ping fa0, however, fa0 cannot ping the PC. Bypassed the switch and got the same results. Any ideas?

Current configuration : 810 bytes

!

version 12.4

service tcp-keepalives-out

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R3

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 25

no ip cef

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

!

!

!

!

!

!

!

!

!

interface Ethernet0

no ip address

shutdown

half-duplex

!

interface FastEthernet0

ip address 192.168.3.1 255.255.255.0

speed auto

no arp arpa

!

interface Serial0

no ip address

shutdown

no fair-queue

!

interface Serial1

ip address 10.2.2.1 255.255.255.252

clock rate 64000

!

no ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

!

control-plane

!

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

login

!

end

R3#

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 7 years 5 months ago

If the PC can ping the router but not the other way round check your PC to see if it has a firewall enabled that is blocking incoming ICMP echo requests.

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Jon Marshall Thu, 08/20/2009 - 11:08

If the PC can ping the router but not the other way round check your PC to see if it has a firewall enabled that is blocking incoming ICMP echo requests.

Jon

delacoadmin Thu, 08/20/2009 - 11:14

Thanx, just installed new IOS and Cisco WIC-2A/S WIC-2AS 2-PORT ASYNC/SYNC SERIAL module, didn't think of the obvious. Any help on why S1 would not be able to ping itself?

Richard Burts Fri, 08/21/2009 - 14:13

William

Based on what we see in the config there might be several reasons why the serial 1 can not ping itself:

- is the interface up? if you do show ip interface brief, does the serial 1 show as up/up? If the interface is not up then it can not ping itself.

- is something connected on the other end of the serial link? On point to point serial interfaces the ping must actually go out the interface, go to the device on the other end, and come back. So if there is no device on the other end the ping will fail.

- is the device on the other end configured with the same protocol (HDLC, PPP, etc)? If the devices are not configured with the same protocol then they can not communicate and the ping will fail.

- is the device on the other end configured with an IP address in the same subnet as your interface. As mentioned before on point to point serial interfaces the ping must go out the interface, get to the other device, which must forward it back on the serial link to you. If the other device is not configured with an IP address in the same subnet then the ping will fail.

HTH

Rick

Actions

This Discussion