VG224 Redundancy - Loopback vs BVI

Unanswered Question

We're going to be deploying 20-30 VG224s at each of our hospitals to support patient room analog phones. We've got an IPTel services block consisting of 2 4948's L3 off of the core. L2 trunk and L3 eigrp adjacency (eigrp) between the 2 4948's. We were initially going to do redundant links on the VG224's with EIGRP & loopback on the VG224 but I recently ran into a (non-cisco) article talking about configuring IRB on the VG224 to create a bridge group and BVI on the VG224 to assign the IP address to. To me it seems simpler & cleaner than configuring eigrp (with stub plus distribute list w/ prefix list, etc) on hundreds of vg224's across the org.


Has anyone configured vg224 redundancy in this manner? Good, bad or indifferenct experience? Opinions? We can't seem to get any solid opinion out of Cisco on the matter.


Thanks !


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
hadbou Wed, 08/26/2009 - 06:16
User Badges:
  • Bronze, 100 points or more

For the Loopback address, you can enter a Loopback address. VG224 does not support EIGRP, it does seem to support RIP and OSPF. RIP could cost you a subnet to have a loopback (not sure if v2 is supported). So please make sure it.

Um, the VG224 most definitely DOES support EIGRP. That is the way that we have redundancy configured initially (2 routed links + loopback, EIGRP stub connected).


The real question was should this be done via L3 as we're doing or does it make more sense to take a L2 approach to redundancy with 2 links, bridge group & BVI on VG224..


Thanks !

I was just attempting to configure this using a BVI but am seeing unacceptable results. Perhaps someone can help:


On my VG224:

!

interface FastEthernet0/0

no ip address

no ip proxy-arp

duplex auto

speed auto

bridge-group 1

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

bridge-group 1

!

interface BVI1

ip address x.x.x.135 255.255.255.224

!

!

ip route 0.0.0.0 0.0.0.0 x.x.x.132 (VLAN Gateway on 3750X stack)

!

bridge 1 priority 65535

bridge 1 protocol ieee

bridge 1 route ip

!


On 3750X:

!

interface GigabitEthernet1/0/1

switchport access vlan 128

switchport mode access

switchport nonegotiate

!

interface GigabitEthernet2/0/1

switchport access vlan 128

switchport mode access

switchport nonegotiate

!       

interface Vlan128

ip address x.x.x.132 255.255.255.224

no ip redirects

no ip proxy-arp

!

spanning-tree mode rapid-pvst

spanning-tree extend system-id


When I start running pings from VG224 to 3750X I drop maybe 5/10000 packets and receive the following error:

*Mar 30 01:03:54.387 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host x.x.x in vlan 128 is flapping between port Gi1/0/1 and port Gi2/0/1

paolo bevilacqua Wed, 07/11/2012 - 08:17
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Thank you for taking the time to report this.

I've rated your post.

Garry Cross Mon, 01/06/2014 - 14:53
User Badges:

You should turn on the locally administered bit in the first byte of the mac address. 00000010

Don't turn on the multicast bit. 00000001

eg don't use 01 or 03 etc. Do use 02, F2, FE, 12 etc

We used 0200.0224.0224,

0123.0123.0123 did not work.

Actions

This Discussion