Duplex full, but hardcoded speed at 100MB could cause input, CRC errors?

Answered Question
Aug 21st, 2009

Folks, imagine a number of gig switchport is set to 100MB, full-duplex.

Device NIC attached to those ports is 10/100/1000MB capable.

I see on the respective switchport, that a number of CRC and input errors are occurring.

I always knew for sure that duplex mismatch could easily cause CRC and input errors. It is not the case here though since it is set to full duplex.

Does it make sense that if we are communicating at 100MB instead of 1Gig we should see input and CRC errors increasing? Strange.

If I set the speed on the Cisco switchport to 'auto', I think it would reset and interrupt the connection, right?

I have this problem too.
0 votes
Correct Answer by Peter Paluch about 7 years 3 months ago

Hello,

If you set both speed and duplex on a port to static values like you did on your GigE ports, you turn off the autonegotiation completely on that interface. That means that it does not send any Fast Link Pulses to inform the neighbor of the capabilities and settings of the port. In this case, the neighboring device must be also statically set to identical values, otherwise it will most probably end in half duplex mode (because it has not negotiated the full duplex with you) and the speed will be simply guessed from the link code present on the link. This guessing and duplex mismatch is probably responsible for the errors you see on the interface.

Therefore, if you set your switchports statically to 100Mbps, full duplex, then you absolutely have to statically set also the NICs on the devices to the same speed and duplex mode.

Best regards,

Peter

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Peter Paluch Fri, 08/21/2009 - 13:09

Hello,

If you set both speed and duplex on a port to static values like you did on your GigE ports, you turn off the autonegotiation completely on that interface. That means that it does not send any Fast Link Pulses to inform the neighbor of the capabilities and settings of the port. In this case, the neighboring device must be also statically set to identical values, otherwise it will most probably end in half duplex mode (because it has not negotiated the full duplex with you) and the speed will be simply guessed from the link code present on the link. This guessing and duplex mismatch is probably responsible for the errors you see on the interface.

Therefore, if you set your switchports statically to 100Mbps, full duplex, then you absolutely have to statically set also the NICs on the devices to the same speed and duplex mode.

Best regards,

Peter

Actions

This Discussion