7937 only registers to SRST

Unanswered Question
Aug 24th, 2009

We have one 7937 that will only register to SRST, bypassing the CUCM completely, (CUCM v6.1.3). This is the only phone in our enterprise having this problem, as well as the only phone on that network segment not registering with CUCM, so I believe it is something specific to the 7937 model (not routing/ACLs/etc.) It is running the latest firmware as well.

EDIT-The log files off the phone show that it is trying to register with the CUCM's DNS name 'CMBE' not its IP address. It then fails out with a DNS error.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (2 ratings)
Brandon Buffin Mon, 08/24/2009 - 12:21

Try to press the services button and then **1 to do a factory reset.

Hope this helps.


cooperben Tue, 08/25/2009 - 06:10

Thanks Brandon. I did do a reset, but the problem persists.

After looking at the phoene and its logs, I can see that the first CM listed is listed by its hostname "CMBE." The phone is trying to register to CMBE, but can't resolve an IP for that hostname. We don't have any DNS set up for our voice VLANs, nor will we.

The reason it doesn't affect all our other phones is because they are using the Option 150 TFTP server IP as CM2. The CM1 field just says CMBE, and is not used by any phone, (because no phone can do name resolution.) The CM2 field is populated by the IP of the CM server and listed as TFTP Active, based on what it receives with Option 150. The CM3 field is listed as SRST and is Standby.

The 7937 in question does not seem to be receiving Option 150. The first CM field is populated by the useless CMBE entry, with the second the SRST entry. It's like it doesn't recognize or use Option 150 for the CM's IP address.

Soooooo, after that long-winded explanation...how do I go about getting the 7937 to grab Option 150 properly? Also, how would I configure the CM to give the phones its IP as CM1, not its hostname? Would this be changing the server name under System-->Server?

This isn't a critical issue because everything is working as is, but this is one of those things that just shouldn't be happening!

Thanks in advance,

Brandon Buffin Tue, 08/25/2009 - 06:16

That is correct. Under System > Server, you should be able to change your CUCM to use an IP address instead of a hostname.


cooperben Tue, 08/25/2009 - 06:20

It gives me a warning that this could cause problems with CallManager. Is this move recommended?

Brandon Buffin Tue, 08/25/2009 - 06:31

Yes. It could cause a problem if your current hostname was pointing to and you changed the server to IP address or if you changed the IP address here, but did not follow the instructions to change the address for the network card. In your situation, you shouldn't see any problems.


cooperben Tue, 08/25/2009 - 07:05

OK, I will try this after hours and post results thereafter. Thanks for your replies.

cooperben Wed, 08/26/2009 - 19:44

OK, that did the trick. After changing the hostname to the IP address under System-->Server, and then resetting all phones, the server's IP is now handed out to all phones instead of its hostname. The 7937 then registered properly.

I guess the moral of this story is to never name your CUCM server anything other than its IP address unless you plan on allowing DNS on your Voice VLANs.


This Discussion