Backup WAN

Unanswered Question
Aug 24th, 2009
User Badges:

Hi


I have EXISTING Lan Extension between two sites A(Cat4006) & B(cat3750).I want to implement Backup LAN extension so that link between two sites is always maintained.Please see below the existing configuration and please tell me what I need to configure on the switches for the backup link to failover in case of primary link failure.I have to use STATIC routing to get this working.


Site A :(Cat4006)


interface FastEthernet3/1

no switchport

ip address 10.100.100.1 255.255.255.248

speed 100

duplex full


ip route 10.32.50.0 255.255.255.0 10.100.100.2

ip route 10.32.52.0 255.255.255.0 10.100.100.2



Site B:(cat3750)


interface GigabitEthernet1/0/24

description LanX HQ

no switchport

ip address 10.100.100.2 255.255.255.248

speed 100

duplex full


ip route 0.0.0.0 0.0.0.0 10.100.100.1


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Peter Paluch Mon, 08/24/2009 - 13:55
User Badges:
  • Cisco Employee,

Hello,


After you install and configure a new link between your switches, you need to add new routing entries to your routing table with a higher administrative distance so that they will become active only if the existing primary connection fails.


On site A, these two lines will be added:


ip route 10.32.50.0 255.255.255.0 X.X.X.X 2

ip route 10.32.52.0 255.255.255.0 X.X.X.X 2


On site B, this line will be added:


ip route 0.0.0.0.0 0.0.0.0 Y.Y.Y.Y 2


where X.X.X.X and Y.Y.Y.Y are addresses of the new interfaces that interconnect your routers. The number 2 at the end of each command is the administrative distance of the route. Normal static routes have administrative distance of 1 which means they are preferred. The administrative distance of these routes has been deliberatly increased to make them less preferred.


For these scenarios, it is also recommended that you define your static routes using both the IP address and the output interface in one command to make sure that the routing entry will be guaranteedly removed from the routing table if the outgoing interface fails, so for example:


ip route 10.32.50.0 255.255.255.0 Fa3/4 X.X.X.X 2

ip route 10.32.52.0 255.255.255.0 Fa3/4 X.X.X.X 2


Best regards,

Peter


CCDECCDE9 Mon, 08/24/2009 - 14:01
User Badges:

Thanks for the answer.


Now,if primary link comes backup does it take over automatically ?

Peter Paluch Mon, 08/24/2009 - 14:10
User Badges:
  • Cisco Employee,

Hello,


Yes, it will - because of its lower administrative distance.


This configuration is sometimes called floating-static routes. You may find this term in the documentation.


Best regards,

Peter


CCDECCDE9 Tue, 10/20/2009 - 13:43
User Badges:

Peter


I have tried this config and then On site B I have unplugged the cable of primary connection to to see it will actually failsover but it did not...Any ideas why...I checked the routes and it did not populate the routing table with the secondary gateway


Thanks

Actions

This Discussion