SIP + NAT

Unanswered Question
Aug 24th, 2009
User Badges:

Hello,

I have IP PBX, NAT router (cisco) and SIP-phone connected as follows:

IP PBX<-internet->NAT router<-LAN->SIP phone

The problem: When I make a call from SIP phone to IP PBX the connecting goes correctly. But when I call from IP PBX to SIP phone the connection does not established. Help to fix it.


NAT router has following config:

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface FastEthernet0/1.89

encapsulation dot1Q 89

ip address 193.109.99.245 255.255.255.248

no ip proxy-arp

ip nat outside

!

ip nat pool ourpool 193.109.89.246 193.109.89.246 netmask 255.255.255.248

ip nat inside source list 10 pool ourpool overload

!

access-list 10 permit 192.168.1.0 0.0.0.255

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
craiglcve Tue, 08/25/2009 - 13:22
User Badges:

What address would the IP PBX be sending the SIP invite to? The issue is that when you call from inside out a nat translation is created that pairs the source address with the destination address. When you call from the IP PBX to the internal phone there is not a translation for the destination. You would need a static translation for the phone so the Router knows who to send the call to.

In a nutshell I think thats whats happening. Hope that helps.

Actions

This Discussion