Can ping from router to internet but cannot ping from client to internet

Answered Question
Aug 25th, 2009
User Badges:

Newbie here looking for help. I have a CISCO ISR 2811, with 1 WC-2T and 1 WIC-1MFT-E1. I have 1 static address from my ISP. I made the basic configuration, but after all, it didn't work. I can ping from the router ios to the internet but cannot ping from my client to the internet. It's so frustating. I think there has something to be with the fact that i haven't configure the nat, but i'm not so sure how to do that. Any help would be much appreciated. Here is my router config. Thanks.



Current configuration : 1257 bytes

!

version 12.4

service config

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname RPrueba

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$uIkt$RMLnTh6zIaB.lzGWeAKgs1

enable password 7 130C19170709073E39257860

!

no aaa new-model

!

resource policy

!

memory-size iomem 15

no network-clock-participate wic 1

ip subnet-zero

!

!

ip cef

!

!

ip name-server 198.6.1.5

ip name-server 198.6.1.142

!

!

voice-card 0

no dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

controller E1 0/1/0

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.240.1 255.255.255.0

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/1

ip address 64.116.x.x 255.255.x.x

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

shutdown

no fair-queue

clock rate 2000000

!

interface Serial0/0/1

no ip address

shutdown

clock rate 2000000

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

!

!

ip http server

no ip http secure-server

!

snmp-server community public RO

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

password 7 0452050303244F5A1B18

login

line aux 0

line vty 0 4

privilege level 15

password 7 020F0A5E07030C355E4F

login

!

scheduler allocate 20000 1000

!

end

Correct Answer by yagnesh_tel about 7 years 8 months ago

interface FastEthernet0/1

ip nat outside


interface FastEthernet0/0

ip nat inside


access-list 102 permit ip 192.168.240.0 0.0.0.255 any


ip nat inside source list 102 interface FastEthernet0/1 overload



Note that ACL 102 identify traffic which should be natted. So make sure you include all your subnets in this ACL which require access.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
yagnesh_tel Tue, 08/25/2009 - 06:29
User Badges:
  • Silver, 250 points or more

interface FastEthernet0/1

ip nat outside


interface FastEthernet0/0

ip nat inside


access-list 102 permit ip 192.168.240.0 0.0.0.255 any


ip nat inside source list 102 interface FastEthernet0/1 overload



Note that ACL 102 identify traffic which should be natted. So make sure you include all your subnets in this ACL which require access.


gustavo-salazar Tue, 08/25/2009 - 08:28
User Badges:

Wonderful, it work. I just did that change and everything work perfect. Now I would try to investigate on my own to see how to handle more ACLs. Thanks a lot for the help.


Gustavo

Actions

This Discussion