LMS 3.2 - No inventory for WS-C2950-24

Answered Question
Aug 25th, 2009
User Badges:
  • Bronze, 100 points or more

Hi,


I have a problem to get inventory data from WS-C2950-24 switches.

SNMP RO+RW is available and telnet, too.


But I get the failure "Device sensed, but collection failed".


I checked the device package, it is "Cat2900XL" its version is 4.0.

Is that the right package for the device with the newest version?


Thanks for any advice!

Correct Answer by Joe Clarke about 7 years 9 months ago

Yep, that's the problem. You need to have all 2950s on 12.1(11)EA1 or higher. All 3550s need to be running 12.1(19)EA1 or higher. This is due to bugs in the switches' ENTITY-MIB implementations.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Joe Clarke Tue, 08/25/2009 - 08:02
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This sounds like a known bug with the software version on the 2950. What version of code is it running?

Sven Hruza Tue, 08/25/2009 - 08:20
User Badges:
  • Bronze, 100 points or more

I didn't look to every of the 60 switches.


But on some of them the version


c2950-i6q4l2-mz.121-6.EA2c.bin


is installed.

Correct Answer
Joe Clarke Tue, 08/25/2009 - 08:24
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Yep, that's the problem. You need to have all 2950s on 12.1(11)EA1 or higher. All 3550s need to be running 12.1(19)EA1 or higher. This is due to bugs in the switches' ENTITY-MIB implementations.

Sven Hruza Tue, 08/25/2009 - 08:32
User Badges:
  • Bronze, 100 points or more

Thanks Joe! Great support :-)


I will look for updating the devices.

Actions

This Discussion