Missing switches in CM 5.0

Unanswered Question
Aug 25th, 2009

Hi all,

I have a problem regarding missing switches in CM. I can see the switches in CS, RME, and DFM but they are not shown in CM. Íf i eg. look in the user defined group in CM, then i can see that 3 switches is missing compered to CS. Alle switches have the exactly the same credentials.

any good ideas ?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Tue, 08/25/2009 - 23:40

Is this really CM 5.0? If so, I would suspect a known bug. I would recommend an upgrade to LMS 3.0.1 with CM 5.0.5, Afterward, a new Campus Data Collection should get your missing devices.

jesper_fr Tue, 08/25/2009 - 23:46

I am running LMS 3.0.1 and CM 5.0.5....sorry. I have all the updates installed

Joe Clarke Tue, 08/25/2009 - 23:49

Okay, what type of switches are they? Are they configured in your Data Collection filters under Campus Manager > Admin > Data Collection > Mode and Policy Settings?

jesper_fr Tue, 08/25/2009 - 23:58

all 3 switches is 3560-48. In the Mode and Policy settings, i have entered a c-class eg. 10.99.66.* . The switches missing is in the midle of this range .93, .96, and .106 switches with the eg. .92, and .107 are shown in CM

Joe Clarke Wed, 08/26/2009 - 00:00

Are they in a cluster configuration? Do you see them under Campus Manager > Admin > Data Collection > Excluded Devices?

jesper_fr Wed, 08/26/2009 - 00:19

No, they are not in a cluster config, and are not shown under excluded devices. I tried to look under included devices, and here i could see the missing switches. I tried to add them manualy, but no change. I still can't see these switches in CM

Joe Clarke Wed, 08/26/2009 - 07:56

After you added them manually, did you run a new Data Collection? That is important as Campus will only manage devices after a Data Collection. You could also enable Data Collection core, corex, frontend, and framework debugging, run a new Data Collection, then check the ani.log for those devices. It is possible they are managed by other names in CM.

jesper_fr Wed, 08/26/2009 - 23:35

I did run a Data Collection after I added these devices manually, but they still doesn't show i CM. I have also enabled logging as described, but i can't see these devices anywhere in the log (searched for IP adr. and device name)

jesper_fr Mon, 08/31/2009 - 23:44

Here is the Ani.log file.

The missing devices is the following:, .95, .98, .102, 106

What device details do you wan't to see ?

Joe Clarke Tue, 09/01/2009 - 08:10

The log is truncated. You will need to increase the log file size under the same interface where you enabled debugging. Add two zeros. Then run a new Data Collection.

jesper_fr Thu, 09/03/2009 - 05:07

after i tried to run a new datacolloection, then the file is too big to upload it here. It's almost 10 MB. What do i do then ?

Joe Clarke Fri, 09/04/2009 - 08:08

It appears there is some bad data in the ANI database preventing these devices from being properly processed. Try reinitializing the topology portion of the database with the command:

NMSROOT/bin/perl NMSROOT/campus/bin/reinitdb.pl

Then run a new Campus Data Collection.

jesper_fr Sun, 09/06/2009 - 22:36

From were (directory) do i run this command on a Windows server ?

Joe Clarke Mon, 09/07/2009 - 03:51

From any directory. NMSROOT is the path into which LMS was installed.

jesper_fr Mon, 09/07/2009 - 04:39

now it works,

after i cleared the campus database and made a new datacollection, then i can see 95 devices compared to before, were i only could see 86 devices.

Thanks very much for all your help :o)


This Discussion