Upgrade LMS 3.2 Syslog file location

Unanswered Question
Aug 26th, 2009

After the upgrade from LMS3.1 to LMS3.2 the syslog file location changed back to the original settings on d:/PROGRA~1/CSCOpx/files/rme/syslog

When I try to change it back to the settings before the upgrade on E:\CW_Syslog\syslog.log suddenly the message:

CEDT0070: You cannot select a file under E:/. You can select a file only under d:/PROGRA~1/CSCOpx/files/rme/syslog.

Comes up. Now the filesystem is getting full, does anyone know how to change this back?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (1 ratings)
Joe Clarke Wed, 08/26/2009 - 07:52

How are you changing the syslog file location. It sounds like you're trying to change the syslog backup location, and the error you're seeing is expected. This would have been the same error as on LMS 3.1.

If you want to change the actual syslog.log file location, use the script NMSROOT\bin\syslogConf.pl:

NMSROOT\bin\perl NMSROOT\bin\syslogConf.pl

Then select the menu option to change the Syslog File Location.

orsonjoon Wed, 08/26/2009 - 10:14

Thanks Joe that did the trick.

But it doesn't change the fact that after the upgrade the syslog location is suddenly changed.

Also strange is that you can't change this from the GUI. This has probably something to do with the deamon manager and all the running processes that are running.

Joe Clarke Wed, 08/26/2009 - 10:26

This was actually raised a long time ago in CSCsd28535, but the fix was to add syslogConf.pl. The syslog file location is actually special in that it is not part of RME, but rather part of Common Services, and stored in the registry. On Solaris, we rely on the Solaris syslogd, and that configuration is found in /etc/syslog.conf. Given that these locations are not backed up as part of the LMS backup, the log file location will revert to the installed locations on a new installation.


This Discussion