ISDN Disconnect Problem

Answered Question
Aug 26th, 2009

Hi,

I have implemented a 2821 VG with 2 E1's PRI, i have a problem with some channels in one of the E1's.

these channels drop the call immediately with Disconnect Cause no resource (47).

I make some debugs and the error when the call is disconnected is

Aug 26 23:59:01.014: ISDN Se1/1:15 EVENTd: process_pri_simple: msg 118, call id 0x804C, bchan 28, call type VOICE

Aug 26 23:59:01.014: ISDN Se1/1:15 SERROR: process_pri_simple: NO name in GTD

Aug 26 23:59:01.014: ISDN Se1/1:15 EVENTd: Packet to CC Data

Aug 26 23:59:01.014: 760101804C00080280AF

a complete debug output for

debug isdn q931

debug isdn q931 detail

debug isdn event

debug isdn event detail

debug isdn error

debug voip ccapi error

debug voip ccapi detail

debug gtd error

debug gtd detail

for the failed call is attached.

The IOS image is C2800NM-ADVIPSERVICESK9-M), Version 12.4(24)T

can you please help me on this. why these channels dropping the call?

Regards,

Abbas

Attachment: 
I have this problem too.
0 votes
Correct Answer by Nicholas Matthews about 7 years 4 months ago

Hi Abbas,

You may be hitting this bug:

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsx67255

What happens is if you have an allocation failure, any future calls over that channel also fail with the same error code.

Check the bottom line of 'show voice dsp group all' to see if you've had any allocation failures.

hth,

nick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
sebastiandm Thu, 08/27/2009 - 03:34

Hi,

It sounds like a DSP issue, have you checked your DSP`s...if you like you could post a show run...

Correct Answer
Nicholas Matthews Thu, 08/27/2009 - 08:37

Hi Abbas,

You may be hitting this bug:

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsx67255

What happens is if you have an allocation failure, any future calls over that channel also fail with the same error code.

Check the bottom line of 'show voice dsp group all' to see if you've had any allocation failures.

hth,

nick

AbbasDadou Thu, 08/27/2009 - 09:22

Hi nick,

Thanks for your post. it was extremely Helpful.

it seems i am hitting the bug i do show voice dsp groups all. and i got "1 DSP resource allocation failure"

So i will try to upgrade to one of the known fixed-IN IOS. and check.

i will let you know if this solve the problem.

Thanks again

Actions

This Discussion