SPA3102 - Connecting to PSTN line but not dialing

Unanswered Question
Aug 27th, 2009

Hello,

I want to make calls from my Dect phone connected to the FXS port of the SPA3102 thru FXO port. The PSTN line is connected to the FXO port. I have added the plan "<#,:>xx.<:@gw0>" to the dial plan of Line 1. When i dial "#" and after hearind dial tone "xxxxxxx" from phone, i see that SPA3102 is connected to PSTN on the Info Tab of administration page. But it never dial the number on PSTN line, and i don't receive any calls, ring at the opposite side. For about 15 seconds, it gives dial tone and then busy tone to me.

I can receive calls from pstn line, and i can make calls thru VOIP.

Can you please help me, what configuration should i change?

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Alberto Montilla Thu, 08/27/2009 - 07:11

Dear Sir;

If there any way you can provide us with the syslog information of the ATA? there could be multiple causes for your issue, the easiest is to check the syslog.

Regards
Alberto

Alberto Montilla Tue, 09/01/2009 - 08:37

Dear Sir;

This must be a config issue as I see calls going and coming, so not actually an issue of the device. Could you please send me the configuration of the device in admin/advanced mode? (same the full html page). Please send it via a private message.

Regards
Alberto

g_strasser Sun, 11/15/2009 - 08:42

Exact same problem, the log shows that the 3102 is trying to dial via the non configured "sip gatway" of the PSTN interface instead of the POTS port.

Can somone explain how to set up the PSTN screen in order for the calls to gw0 to be routed on the POTS

Thanks

Gabriel

DIAL Plan:
011x.<:@gw1>|0<:@gw0>|[2-79]11<:@gw0>||xx*|*xx|xxx[2-9]xxxxxxS0|xxxxxxxxxxxx.
|<#9,:>xx.<:@gw0>)
^^^^^^^^^^^^

Log:

Nov 15 08:47:56 192.168.1.101 [0]Off Hook
Nov 15 08:47:58 192.168.1.101 2. Report digit # (1)(40 ms)
Nov 15 08:47:59 192.168.1.101 2. Report digit 9 (1)(40 ms)
Nov 15 08:47:59 192.168.1.101 [0]PlayOutDial 1
Nov 15 08:48:00 192.168.1.101 2. Report digit 9 (1)(40 ms)
Nov 15 08:48:01 192.168.1.101 2. Report digit 0 (1)(40 ms)
Nov 15 08:48:01 192.168.1.101 2. Report digit 5 (1)(40 ms)
Nov 15 08:48:01 192.168.1.101 2. Report digit 8 (1)(40 ms)
Nov 15 08:48:02 192.168.1.101 2. Report digit 8 (1)(40 ms)
Nov 15 08:48:02 192.168.1.101 2. Report digit 1 (1)(40 ms)
Nov 15 08:48:02 192.168.1.101 2. Report digit 7 (1)(40 ms)
Nov 15 08:48:03 192.168.1.101 2. Report digit 1 (1)(40 ms)
Nov 15 08:48:03 192.168.1.101 2. Report digit 3 (1)(40 ms)
Nov 15 08:48:03 192.168.1.101 2. Report digit 3 (1)(40 ms)
Nov 15 08:48:06 192.168.1.101 Calling:[email protected]:5061
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Nov 15 08:48:06 192.168.1.101 [0:0]AUD ALLOC CALL (port=16396)
Nov 15 08:48:06 192.168.1.101 [0:0]RTP Rx Up
Nov 15 08:48:06 192.168.1.101 [0]->127.0.0.1:5061(897)
Nov 15 08:48:06 192.168.1.101 [0]->127.0.0.1:5061(897)
Nov
15 08:48:06 192.168.1.101 ;tag=b4961bf514264e1bo0 To:
Remote-Party-ID: 9994172560
[email protected]>;screen=yes;party=calling
Call-ID: [email protected] CSeq: 101 INVITE Max-Forwards:
70 Contact: 9994172560
Expires: 120 User-Agent: Linksys/SPA3102-5.1.10(GW) Content-Length: 251
Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER
Supported: x-sipura, replaces Content-Type: application/sdp v=0 o=-
3853 3853 IN IP4 192.168.1.101 s=- c=IN IP4 192.168.1.101 t=0 0 m=audio
16396 RTP/AVP 0 100 101 a=rtpmap:0 PCMU/8000 a=rtpmap:100 NSE/8000
a=fmtp:100 192-193 a=rtpmap:101 telephone-event/8000 a=fmtp:101 0-15
a=ptime:30 a=sendrecv
Nov 15 08:48:06 192.168.1.101 

Alberto Montilla Tue, 11/17/2009 - 03:40

Dear Sir;

Can you please set the rule|<#9,:>xx.<:@gw0>) on the left of the dial plan (at the beginning), just want to make sure the dial plan is reading first another entry which may be in conflict.

Regards
Alberto

g_strasser Tue, 11/17/2009 - 04:42

Thank for your attention,

Done as suggested, see trace below. Still the call that supposed to go out on gw0 / POTS port is sent to "127.0.0.1:5061"

Just in case I attached the config of the ATA.

dial plan is re ordered:

From:

(011x.<:@gw1>|0<:@gw0>|[2-79]11<:@gw0>||xx*|*xx|xxx[2-9]xxxxxxS0|xxxxxxxxxxxx.|<#9,:>xx.<:@gw0>)

To:

(<#9,:>xx.<:@gw0>|011x.<:@gw1>|0<:@gw0>|[2-79]11<:@gw0>||xx*|*xx|xxx[2-9]xxxxxxS0|xxxxxxxxxxxx.)

Trace:

Nov 17 07:26:07 192.168.1.101 DLG Terminated 2eb858
Nov 17 07:26:07 192.168.1.101 [0]Off Hook
Nov 17 07:26:08 192.168.1.101 2. Report digit # (1)(40 ms)
Nov 17 07:26:09 192.168.1.101 2. Report digit 9 (1)(40 ms)
Nov 17 07:26:09 192.168.1.101 [0]PlayOutDial 1
Nov 17 07:26:10 192.168.1.101 2. Report digit 4 (1)(40 ms)
Nov 17 07:26:10 192.168.1.101 2. Report digit 1 (1)(40 ms)
Nov 17 07:26:10 192.168.1.101 2. Report digit 6 (1)(40 ms)
Nov 17 07:26:12 192.168.1.101 2. Report digit 5 (1)(40 ms)
Nov 17 07:26:13 192.168.1.101 2. Report digit 8 (1)(40 ms)
Nov 17 07:26:13 192.168.1.101 2. Report digit 5 (1)(40 ms)
Nov 17 07:26:15 192.168.1.101 2. Report digit 5 (1)(40 ms)
Nov 17 07:26:15 192.168.1.101 2. Report digit 8 (1)(40 ms)
Nov 17 07:26:17 192.168.1.101 2. Report digit 0 (1)(40 ms)
Nov 17 07:26:17 192.168.1.101 2. Report digit 2 (1)(40 ms)
Nov 17 07:26:20 192.168.1.101 Calling:[email protected]:5061
Nov 17 07:26:20 192.168.1.101 [0:0]AUD ALLOC CALL (port=16404)
Nov 17 07:26:20 192.168.1.101 [0:0]RTP Rx Up
Nov 17 07:26:20 192.168.1.101 [0]->127.0.0.1:5061(899)
Nov 17 07:26:20 192.168.1.101 [0]->127.0.0.1:5061(899)
Nov 17 07:26:20 192.168.1.101 ;tag=971df0d4879af597o0  To: [email protected]:5061>  Remote-Party-ID: 9994172560 [email protected]>;screen=yes;party=calling  Call-ID: [email protected] CSeq: 101 INVITE  Max-Forwards: 70  Contact: 9994172560   Expires: 120  User-Agent: Linksys/SPA3102-5.1.10(GW)  Content-Length: 253  Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER  Supported: x-sipura, replaces  Content-Type: application/sdp    v=0  o=- 73180 73180 IN IP4 192.168.1.101  s=-  c=IN IP4 192.168.1.101  t=0 0  m=audio 16404 RTP/AVP 0 100 101  a=rtpmap:0 PCMU/8000  a=rtpmap:100 NSE/8000  a=fmtp:100 192-193  a=rtpmap:101 telephone-event/8000  a=fmtp:101 0-15  a=ptime:30  a=sendrecv 
Nov 17 07:26:20 192.168.1.101

Alberto Montilla Sat, 11/21/2009 - 07:59

Dear Sir;

I would suggest you do the following:

(1) Please downgrade the device to 5.1.7 and then factory reset it (this would require you type in again your dial plan and configuration, so please save the config before doing the factory reset).

(2) Reconfigure the device and try again.

There is a bug on 5.1.10 which may be causing the issue, so I suggest we continue the debug on 5.1.7 to ensure this is not related to this other bug.

The config is showing like the PSTN line is not connected.

Regards
Alberto

Actions

This Discussion

Related Content