ACE webhost-redirection question

Unanswered Question
Aug 27th, 2009
User Badges:

I have a rserver configured with the following line.


webhost-redirection https://%h/%p 301


I encounter a problem if I enter something such as http://mywebsite.abcd.com


The site does not redirect to https. However if I retype adding a / at the end everything works.


http://mywebsite.abcd.com/


Is there an easy way to correct this so that users do not need to enter a / ? I'm trying to keep it simple so that the rule works with or without a URL.


Thanks,

jeramy

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Gilles Dufour Thu, 08/27/2009 - 11:50
User Badges:
  • Cisco Employee,

How do you match the traffic that needs to be redirected ?


do you have a sniffer trace of the connection ?

It would be interesting to see what the request looks like.

Is it "GET HTTP/1.1" ??


Also, what version do you run ?


Gilles.

ciscocsoc Thu, 08/27/2009 - 23:30
User Badges:
  • Silver, 250 points or more

Hi Jeramy,


Try removing the extra / in the redirection i.e.

https://%h%p 301.


Kind Regards


Cathy

ciscocsoc Thu, 08/27/2009 - 23:30
User Badges:
  • Silver, 250 points or more

Oops. Hit "Post" twice.



JeramyKoval Tue, 09/01/2009 - 05:44
User Badges:

Thanks for the responses. Sorry to take so long to respond. I've been swamped by this CSS to ACE migration.


It appears my problem has been resolved. On Friday I upgraded our ACE modules from 2.1.5 to 2.2.1 and since then I have not been able to recreate the problem.


Now I'm in the process of getting our ANM server updated to 2.2 and our AXG/WAFs updated to 6.03.



JeramyKoval Tue, 09/01/2009 - 07:56
User Badges:

John,


I really like the ANM product but I find it most useful post-migration. All of my CSS to ACE migrations are done at the CLI. ANM makes it easier to monitor, configure and troubleshoot once you have a context up and running.


The biggest advantage for me has been that the ANM product cut down on the amount of time I've had to spend in cross training my team. Great group of guys but they struggled with policy maps, class maps, etc. With ANM they don't have to worry about that since it's done behind the scenes.


I had the pleasure of meeting with Mark Dittmer this past Friday. He's one of the TMEs at Cisco. I got a sneak peak at ANM 3.0 and it is impressive. They have made some nice changes to the GUI and added much more to the product. New wizards and tooltips to make it even easier to work with. I was really impressed.


My only gripe was the Red Hat requirement but I believe that my be changing in the future as well.



Actions

This Discussion