SPA941 resuming held call, jumps to speaker phone

Unanswered Question
Aug 28th, 2009

I have a linksys SPA941

When I put a call on hold, and then resume the call,

the phone automatically jumps to speaker

then when I press the speaker button to take it off speaker the call gets cut off

Anything I can do in the config to resolve this?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
William Childs Fri, 08/28/2009 - 20:26

Patrick,

Please post your config. Have you tried a factory default and reconfiguration of the phone from scratch? What are you using for your PBX? How is that line configured in the phone (shared/private, is it monitored or set for speed dial/call pickup)? Also, does this happen with local calls, external calls, or both?

Bill

patrick.conway@... Mon, 08/31/2009 - 01:22

Hi Bill,

The phone was right out of the box and I had just entered sip settings, so factory reset was not necessary.

The problem was happening on all held calls.

I resolved by changing "Prefered audio device" from speaker to headset in user settings.

(We dont use headsets so it seems to default to the handset now, instead of speaker which it had done before)

thanks

William Paulsen Wed, 04/21/2010 - 05:40

Was there a resolution to this problem?

This happens about 20% of the time:  When a phone rings or a call is on hold, and the handset is removed from the cradle, the call goes to the speaker phone instead of the handset.  The you need to put the handset back into the cradle and pick it up again, and maybe (90% of the time) the call is on the handset.

This happens on SPA504g phones with latest firmware.  It happens on all kinds of calls:  inside, outside, transfers, holds.


And this behavior is very annoying to the client - what can be done???

patrick.conway@... Wed, 04/21/2010 - 06:09

In the setting sof the phone, under User Tab

I set preferred audio device to headset ...default is speaker

William Paulsen Wed, 04/21/2010 - 13:59

Sorry, but that doesn't work.  Setting User/Preferred Audio Device to "Headset" instead of "Speaker" simply changes the device that is supposed to be used when you dial without lifting up the handset.  The "headset" is something that can be plugged into the mini audio jack on the side of the phone.  (Note: The headset is not the same as the handset).

So if Preferred Audio Device is set to Headset, and you don't have a headset plugged in, and you dial without picking up the handset, then nothing will happen.  If the device is set to Speaker (the default), then your call is placed on speaker phone.

So - does anyone have an answer to this?

Or do I need to try to open yet another issue ticket with Cisco support? But that's always a dead end.

patrick.conway@... Thu, 04/22/2010 - 01:14

I dont know what you mean "nothing will happen"

What happens for me if I dial without lifting up the handset, without a headset plugged in, is....

the call will be made, but audio device selected will be headset.

I just press the speaker phone button to change to speaker

ok...its replacing one problem with another, but having to press the speaker button when dialing is less annoying than the phone randomly going to speaker during a call

William Paulsen Thu, 04/22/2010 - 04:44

I doubt the staff could ever understand your suggested work-around for this problem that's really in the phones.  And just suppose Cisco could ever fix this problem (but not likely I suspect, given their track record with other issues), then the staff would need to undo this work-around and they'd never understand that either.