STP Issues and HOSTFLAPPING over two path

Unanswered Question
Aug 28th, 2009

I have issues across two 4500 switches interconnected by pry and backup link.

The Pry(prymary) link is a Lan eXtension

The Backup link has additional swithces in between performing Q-in-Q(L2TP)

on the two 4500 switches pry and Backup links interfaces are configured as TRUNKs

If the two interfaces are up at the same time we experience FLAPPING %C4K_EBM-4-HOSTFLAPPING: However if either one the prymary or the backup link is UP at a time everything is fine but there will not be auto link failover.

How can i have both links up and have Auto failover in this L2 enviroment ?

I have used spanning-tree cost and priority and does not help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Mohamed Sobair Fri, 08/28/2009 - 12:12


could you let us know , what is the root bridge for the current vlans on the 4500.

why did you use spanning-tree cost and priority commands ??



sanyaolu Fri, 08/28/2009 - 12:38


See attach config

I use use spanning-tree cost and priority commands while looking for solutions

-------- -------

| |

SwitchA|-------Pry Gi1/6---------|SwitchB

| |


------- --------

Francois Tallet Fri, 08/28/2009 - 12:43

Your L2TP is most likely messed up. Switch A & B don't see each other through the backup link (2/6--C--D---2/6).

Start from switch D and check whether is received any information from switch C. If not, check if C gets anything from D.

The spanning-tree command you enter are just useful to do some tuning on the topology once everything works fine, you're not there yet unfortunately:-(



sanyaolu Fri, 08/28/2009 - 13:00


When i shut the prymary link. and enable the interfaces 2/6 on switch A and B it works okay.

If i do sho cdp nei on switch A via pry link, i see swithces A and B as neigbours directely

If i do sho cdp nei on switch A via bkup link i only see the directly connected swithces C and not Switch B (Which is the issue)

Here is the topology

swthA gi1/6------------------gi1/6 switchB

swthA gi2/6---QinQ_SwthC---Trunk-bkup---QinQ_SwthD---gi2/6 switchB

Francois Tallet Fri, 08/28/2009 - 13:06

I saw that A & B could see each other directly via 1/6. However, at least in the show command included, there is no STP communication through the second path: swthA gi2/6---QinQ_SwthC---Trunk-bkup---QinQ_SwthD---gi2/6 switchB

Assuming that you did not have any interface shutdown when collecting those show commands, that's where your problem resides: BPDUs are not exchanged between A & B via this path. That's where you should concentrate your troubleshooting at that stage.

sanyaolu Fri, 08/28/2009 - 14:09

I did some additional show commands when the two links are up. See the capture attached.

What should i do to make Swicth A see Swicth B. I have access to switches A,B,C and D.

Francois Tallet Mon, 08/31/2009 - 06:08

Unfortunately, there is nothing much more to be seen here. You have to troubleshoot the lack of BPDU exchange on ports 2/6. The role is designated at both ends of this connection A 2/6 --- 2/6 B which means than BPDUs don't go through.



Giuseppe Larosa Mon, 08/31/2009 - 07:09

Hello Adelou,

as Francois has noted on the link carried in the QinQ service no STP BPDUs flow.

also the fact you see as CDP neighbor the "provider" switch instead of switchB points to an issue with l2 protocols transport over QinQ.


both CDP and STP tunneling needs to be explicitly configured on the "provider" side.

Hope to help


Mohamed Sobair Tue, 09/01/2009 - 13:06


As indicated by Francois, the switch ports on both Switch A and B backup link doesnt exchange BPDUs.

Could you please post the config of sitch C & D and let us know the Q-in-Q config on the ports? Have you any BPDU filter set?




This Discussion