Dynamic Multipoint GRE Tunnel .......

Unanswered Question
Aug 28th, 2009
User Badges:
  • Silver, 250 points or more

R3: -- HUB Router

R4: -- Cloud

R5: -- Spoke Router


As discussed in above scenario I am not able to ping from R3 to R5 in GRE Multimode Tunnel. Actually I want to run OSPF over Dynamic Multipoint IPSec VPNs (Using Multipoint GRE NHRP)


R3#

R3#sh run

R3#sh running-config

Building configuration...

Current configuration : 1520 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R3

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

resource policy

!

memory-size iomem 5

ip cef

!

interface Tunnel1

description ********* TUNNEL INTERFACE TO R5 ********

ip address 172.30.1.2 255.255.255.0

no ip redirects

ip mtu 1416

ip nhrp map multicast dynamic

ip nhrp network-id 5050

ip nhrp holdtime 100

tunnel source FastEthernet0/0

tunnel mode gre multipoint

!

interface Loopback1

description ******** LAN INTERFACE ********

ip address 192.168.10.1 255.255.255.0

!

interface Loopback2

description ******** LAN INTERFACE ONE ********

ip address 192.168.11.1 255.255.255.0

!

interface FastEthernet0/0

description ******* WAN INTERFACE *********

ip address 1.1.1.1 255.255.255.0

duplex auto

speed auto

!

ip route 0.0.0.0 0.0.0.0 1.1.1.2

!

ip http server

no ip http secure-serve


control-plane

!

!

line con 0

line aux 0

line vty 0 4

!

!

end



R4#sh run

R4#sh running-config

Building configuration...


Current configuration : 1046 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R4

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

memory-size iomem 5

ip cef

!

interface FastEthernet0/0

description ******** WAN TO R3 ************

ip address 1.1.1.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

description ******** WAN TO R5 ************

ip address 2.2.2.1 255.255.255.0

duplex auto

speed auto

!

ip http server

no ip http secure-server

!

control-plane

!


line con 0

line aux 0

line vty 0 4

!

end


R5#sh run

R5#sh running-config

Building configuration...


Current configuration : 1570 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R5

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

memory-size iomem 5

ip cef

!

!

interface Tunnel1

description **********TUNNEL INTERFACE TO R3********

ip address 172.30.1.1 255.255.255.0

no ip redirects

ip mtu 1416

ip nhrp map multicast 1.1.1.2

ip nhrp map 172.30.1.2 1.1.1.2

ip nhrp network-id 5050

ip nhrp holdtime 100

ip nhrp nhs 172.30.1.2

tunnel source FastEthernet0/1

tunnel mode gre multipoint

!

interface Loopback1

description ******* LAN INTERFACE ********

ip address 192.168.1.1 255.255.255.0

!

interface Loopback2

description ******* LAN INTERFACE ONE ********

ip address 192.168.2.1 255.255.255.0

!

ip route 0.0.0.0 0.0.0.0 2.2.2.1

!

ip http server

no ip http secure-server

!

control-plane

!

line con 0

line aux 0

line vty 0 4

!

end


R5#


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Peter Paluch Sat, 08/29/2009 - 00:29
User Badges:
  • Cisco Employee,

Hello,


I do not see the configuration of the Fa0/1 interface in the R5 output but I assume that it is present and configured OK.


There is a typo in the Tunnel1 configuration on the R5: you have mapped the tunnel IP address 172.30.1.2 to the real IP 1.1.1.2. Notice that this is wrong - this points to the R4 that is only a cloud. It should correctly point to 1.1.1.1 - the R3. The correct line on R5 should be therefore:


ip nhrp map 172.30.1.2 1.1.1.1


Best regards,

Peter


Actions

This Discussion