ADSL Config

Unanswered Question
Aug 30th, 2009

Hi All,

I have 2811 router with HIW-1ADSL card, i need to configure this router for internet connection. I have already one ADSL Linksys router up and running the configuration of that Linksys router as follows

Encapsulation : RFC 2516 PPPOE

pcr rate :cps

scr rate :cps

virtual circuit: vpi=0

vci=50

DSL Modulation : Multimode

PPPOE setting:

username : John

password : XXXX

connect on Demand : yes

Max idle timeo out : 5 mints

can you help to do the same configuration in above said cisco 2811 router.

thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Sun, 08/30/2009 - 00:48

Hello Jagan,

for releases after IOS 12.2(13)T the following is enough:

suppose that atm0/0 is the name of the DSL interface on your router

interface ATM0/0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/50

enc aal5snap

pppoe-client dial-pool-number 2

!

interface Dialer2

description PPPoEoverATM

mtu 1492

ip address negotiated

encapsulation ppp

dialer pool 2

dialer-group 2

dialer idle-timeout 300

ppp chap hostname John

ppp chap password XXXX

ppp pap sent-username John password XXXX

!

dialer-list 2 protocol ip permit

ip route 0.0.0.0 0.0.0.0 dialer2 200

you need also to NAT the internal interface to allow internet access from inside.

int fas0/0

ip address 192.168.34.1 255.255.255.0

ip nat inside

access-list 11 permit 192.168.34.0 0.0.0.255

int dialer2

ip nat outside

ip nat inside source list 11 int dialer2 overload

see

http://www.cisco.com/en/US/docs/ios/bbdsl/configuration/guide/bba_ppoe_client_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1058537

Hope to help

Giuseppe

jagan_240 Thu, 09/17/2009 - 03:32

Hi Giuseppe,

I have configured ADSL router im getting ip address to my outside interface and atm interface is showing up. But i can't able to access internet. When i issued "debug atm error"

i got following message.

*Sep 17 11:18:15.415: dslsar_ng_transmit_pak_wrapper: deq(474FE2D4). ATM vcd=1 Transmit VCD=1

*Sep 17 11:18:15.415: dslsar_ng_transmit_pak_wrapper : encap = Data

*Sep 17 11:18:25.655: dslsar_ng_transmit_pak_wrapper: deq(46DEC6E8). ATM vcd=1 Transmit VCD=1

*Sep 17 11:18:25.655: dslsar_ng_transmit_pak_wrapper : encap = Data

*Sep 17 11:18:31.535: dslsar_ng_transmit_pak_wrapper: deq(46DED204). ATM vcd=1 Transmit VCD=1

*Sep 17 11:18:31.535: dslsar_ng_transmit_pak_wrapper : encap = Data

*Sep 17 11:18:35.895: dslsar_ng_transmit_pak_wrapper: deq(46DEE83C). ATM vcd=1 Transmit VCD=1

*Sep 17 11:18:35.895: dslsar_ng_transmit_pak_wrapper : encap = Data

*Sep 17 11:19:47.575: dslsar_ng_transmit_pak_wrapper: deq(474FEDF0). ATM vcd=1 Transmit VCD=1

*Sep 17 11:19:47.575: dslsar_ng_transmit_pak_wrapper : encap = Data

*Sep 17 11:19:57.815: dslsar_ng_transmit_pak_wrapper: deq(46DEFAC0). ATM vcd=1 Transmit VCD=1

*Sep 17 11:19:57.815: dslsar_ng_transmit_pak_wrapper : en ip virtual-reassembly

kindly assist me on this issue.

regards,

Jagan

jagan_240 Thu, 09/17/2009 - 03:51

Hi Giuseppe,

This issue is resolved it an ppp authentication issue.

Thanks a lot in assisting me on this issue.

regards,

Jagan

Actions

This Discussion