MPLS (cannot ping my remote network).

Answered Question
Aug 31st, 2009

I have configured my 2 routers(7613 & 7609) to be my PE's, my 6500 to be CE's for a basic mpls test. When I do my "sh ip route vrf VPNTEST1" I can see my route's but I can't ping any of those route. I can only ping the loopback that are connected directly to my PE's not the remote loopback that is learned via bgp. Loopback 3.3.3.3 is for the switch that is directly atached to CR7613PE (router) and loopback 4.4.4.4 is directly connected to CR7609PE

Any Idea what could be the problem? Attached are my configs.

Attachment: 
I have this problem too.
0 votes
Correct Answer by jon.harald.bovr... about 7 years 3 months ago

Usually when iBGP sessions are configured between loopbacks - and not between linkadresses

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
jon.harald.bovr... Mon, 08/31/2009 - 04:47

interface Loopback0

ip address 2.2.2.2 255.255.255.255

Loopback 0 on both PE has been configured with 2.2.2.2/32.

Reload or force LDP id update when this has been resolved

shivlu jain Mon, 08/31/2009 - 05:28

jon is right,for BCP configure loopback 0 as bgp router id. otherwise you will face issue if ldp router id and mp-ibgp router id get different.

regards

shivlu jain

jon.harald.bovr... Mon, 08/31/2009 - 05:38

Something to look into:

Assume Loop0 on 7613 was meant to be 1.1.1.1/32

BGP between link adress, with update source loop0?

BGP next-hop problems with above BGP config?

Cannot see why 'send-label' are configured on PE-CE link, unless you are doing CsC

Not shown in configs - but as-override on PE-CE BGP would be needed with AS6501 on both CE's

Correct Answer
jon.harald.bovr... Mon, 08/31/2009 - 06:49

Usually when iBGP sessions are configured between loopbacks - and not between linkadresses

tahiryasin Mon, 08/31/2009 - 11:02

You need to use ping VRF command not regular PING command .

Thanks

tahiryasin Mon, 08/31/2009 - 11:11

Also in your config two AS's do not match you have

neighbor 172.100.0.2 remote-as 6501

but there is not As 6501 ,you need to fix this before all VRF routes can be imported.

Thanks

Actions

This Discussion