NAT question

Unanswered Question
Aug 31st, 2009

I have a quick question here...I have a /27 NAT block that is part of my ethernet interface to a customer. Now I ran out of nats in that block and am now requesting another /27. So the quesiton is do I just add this as a secondary ip address or how do I get this going?

Thank you in advance for your help!!

Please see attached we are looking at CME

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Edison Ortiz Mon, 08/31/2009 - 07:33

You don't need a secondary IP address on the current NAT outside interface to get this going. You need to make sure you are advertising the new /27 subnet so you can draw the traffic to this router.

You can go with the static to null0 approach and redistribute into OSPF just like the way you are doing now with your current /27 redistribute connected subnets route-map redis-connected. The null0 will be redistributed with redistribute static subnets route-map redis-static so make sure to adjust the route-map to allow this route.

HTH,

__

Edison.

wgranada1 Mon, 08/31/2009 - 07:43

Hi Edison;

Sorry not sure I follow...

The current /27 is 172.20.26.96/27 not sure yet what the other /27 will be as of yet. So all I have to do is add a null0 but how will it know how to exit the right interface?

interface FastEthernet1/9

description CME20 meg man CME4075

switchport access vlan 26

duplex full

speed 100

!

interface FastEthernet1/10

description CME20 meg man CME4076

switchport access vlan 26

duplex full

speed 100

!

interface Vlan26

description CME20 meg man

ip address 172.20.26.100 255.255.255.224

ip nat outside

ip virtual-reassembly

Edison Ortiz Mon, 08/31/2009 - 07:50

As the packet is translated, it will use the routing table to reach the destination address.

The null0 is for the NAT subnet advertisement.

Based on your network, say 168.162.126.168 wants to reach 4.2.2.1 - it enter this router via 'an ip nat inside' interface and it matches for NAT - the packet gets translated and routed out of the interface closest to 4.2.2.1. The null0 on this case is for 4.2.2.1 to reach back to the NATed IP address on this router.

HTH,

__

Edison.

wgranada1 Mon, 08/31/2009 - 07:58

ok I believe I go it, I will configure tonight and let you know. This will see if I really got it or not. thank you for your help!!!

Edison Ortiz Mon, 08/31/2009 - 08:48

I will also recommend entering a description on the static route so other engineers will know what it is for...

For instance;

ip route 1.1.1.0 255.255.255.240 null0 name NAT_Subnet_DO_NOT_DELETE

In addition, we also recommend that you rate helpful posts in these forums.

Regards.

wgranada1 Mon, 08/31/2009 - 08:52

Oh I know what happened I didn't hit submit all I did was rate it but then hit reply instead of submit and then reply. sorry.....

Actions

This Discussion