Device count is different in Common services home page

Unanswered Question
Aug 31st, 2009
User Badges:

Hi,


I can see the number of devices count is diifferent in common services home page under Device credential and Admin tab. If go to Device and credentials -> Device Discovery page there i can see the total number of devices discovered is different. Could you please explain this difference in number of devices?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 08/31/2009 - 21:44
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Discovery will show both reachable and unreachable devices. Only reachable devices are sent to DCR. Additionally, if LMS is integrated with ACS, only those devices in ACS will be seen as being in DCR on the Common Services homepage.

akash03lingam Mon, 08/31/2009 - 22:05
User Badges:

ok, thanks for you information.


Another question, I am having problem of devices are added to ciscoworks but those devices not updated in DCR. May i know the reason for this? how can i make those devices added to DCR.


Joe Clarke Mon, 08/31/2009 - 22:15
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Is LMS integrated with ACS?

Joe Clarke Mon, 08/31/2009 - 22:22
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Then make sure all of the devices you want to manage are added as clients of the ACS server. Once you do, then logout of LMS, and log back in. Then you will see all of the missing devices in DCR. In the meantime, the missing devices will show up under the Common Services > Device and Credentials > Reports > Devices not in ACS report.

akash03lingam Mon, 08/31/2009 - 22:29
User Badges:

We have started the device discovery manually, that time the "Devices updatedd to DCR" column showing correct number of devices for some time may be one hour but after some time again the "Devices updated to DCR" column showing wrong number of devices.

Joe Clarke Tue, 09/01/2009 - 08:04
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Then discovery must have run again. The numbers only change when a Discovery runs. It then caches the data to a file on disk.

akash03lingam Tue, 09/01/2009 - 19:18
User Badges:

Can you please tell me why the number of devices changes in the "Total number of devices discovered" in Devices and credential Tab frequently. It means the devices present in the Devices and credentials tab only added to the DCR. How can i make other devices add to DCR. All the devices are integrated with ACS.

But some devices are not added to DCR.


Joe Clarke Tue, 09/01/2009 - 19:22
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Just so we're on the same page, post screenshots showing the device count discrepancies you're seeing. Also, post the output of the Common Services > Device and Credentials > Reports > Devices that are not configured in ACS Report.

akash03lingam Tue, 09/01/2009 - 19:44
User Badges:

I have attached the screenshots of the devices count in common services home page and device discovery summary. When i generated a report for devices are not confifured in ACS i got one error. I have attached that error message also. Please find it.



Joe Clarke Tue, 09/01/2009 - 20:26
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The error means you are NOT integrated with ACS.


The device counts in screenshot 2 only change when Discovery runs. So if they are changing periodically, then you must be starting new Discoveries. The 170 number here means that 170 devices were reachable, and thus those were sent to DCR.


The 212 number in screenshot 1 shows the total number of devices in DCR. This can be different the number of devices discovered because you could add devices to DCR which cannot be found during Discovery. If you want Discovery to use all the devices in DCR as seeds when it runs, then enable the "Use DCR as Seed List" option under the Global Discovery module.

akash03lingam Thu, 09/03/2009 - 21:52
User Badges:

I got this error report ehen i was generating a report "Devices not configured in ACS"

The error screenshot i have attached means that LMS is not integrated with ACS. But i have set my Authentication mode to TACACS+. Can you please explain the difference and solution.



Joe Clarke Thu, 09/03/2009 - 22:01
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Using TACACS+ authentication is not the same as ACS integration. ACS integration gives you both authentication and authorization control. You can create custom roles, and restrict device access. TACACS+ authentication only gives you the ability to centralize user accounts.

akash03lingam Thu, 09/03/2009 - 22:05
User Badges:

Is there any document how to integrate LMS with ACS or please explain the process.

Actions

This Discussion