CUEAC - Administrative Webpage Error

Unanswered Question
Sep 1st, 2009

Hello,

I'm attempting to get my first CUEAC 3.0.1.4 installation up and working. The installation completed successfully with zero errors or warnings. I check the event log and it does not appear to be reporting any errors or issues either. Unfortunately, when I attempt to log into the administrative webpage to begin my configuration, it returns an error:

Unable to connect to the server.. Error Data : API_NOT_INITIALIZED

The only correlating error that I can find is in the aacmlog file:

9/1/2009 13:47:11.749|M|"002""800""TDbConfigMgr""TDbConfigM gr.ProcessRequest""Both clients blocked request. RequestType: 1, RequestSubType: 1, Processed: 0, Result: -1, LastError: 30, MSIAccept: 30, DBServerAccept: 30"

Everything is co-resident and there is no firewall enabled on the server so I don't believe it's a network issue.

I have an existing Cisco TAC case open but I haven't had much luck with it thus far. I was hoping that perhaps the collective wisdom of the masses might be able to assist here.

Thanks for any help,

Justin

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
justinbois Fri, 09/04/2009 - 04:26

For those interested parties (if any), I'm still working with Cisco who has since escalated to ARC on this. I worked with an ARC engineer last night for a few hours and we're now going to their developers on this. It appears that I "found a good one".

I'll post the solution/work-around/fix that I used as soon as I find one.

Thanks.

Justin

tecgsmitte Tue, 10/13/2009 - 06:48

Hi,

I am having the same issue with CuBAC 2.0.1.14. I installed the Server and the Client on a Win Xp Machine. Maybe i need to go for Windows 2003 as OS.

Did you resolved the issue with ArcSolutions?

kindly regards,

Bernhard

justinbois Tue, 10/13/2009 - 06:56

Hello,

I actually DID get this squared away. It turns out it was an issue with installer in general. By default the CUxAC installer looks for the 'Administrator' account on the local server. The environment I was installing into actually has renamed the stock 'Administrator' account to something else, then created a dummy account with zero privileges named administrator. The install process was using that dummy account and trying to use it to start services related to IIS. Changing the services that IIS uses to run as to an account with the appropriate permissions fixed the issue on my end.

Additionally, disabling the integrated windows authentication on the webadmin IIS site seemed to have helped.

The end result was a permissions issue across the board for me (including the CUxAC client itself- it needs admin rights to work correctly).

hth

Bois

tecgsmitte Tue, 10/13/2009 - 22:57

Hi,

Thanks for your reply. I am actually installing it with the local administrator account and still have the problem. I see that all services are running with the local system account. I see there error messages: Login failed for user 'sa'.

Thats strange, the SQL Server 2005 Express has been installed with CUBAC, so password should be ok. when i try to logon to the database with the cisco credentials mentioned at documentation it won't work.

On datasheet i see the requirements:

Windows 2000 or 2003 Server plus SP2 running Windows English Regional settings.

So we can't get it running on Win XP and you need to setup english regional settings... Does it mean the english windows version or just change to english-us at regional settings?

kindly regards,

Bernhard

justinbois Wed, 10/14/2009 - 04:32

Interesting. The Local Administrator account is actually called "Administrator", right? Assuming that's the case, you might want to try and reset the 'sa' password to what the documentation uses by default: "Z1ppyf0rever" (minus quotes). Google should hook you up on that with minimal effort.

I ran into a similar issue and it was easier to make sure the sa password was the expected one rather than try and fight the application to use the password I wanted.

Justin

Actions

This Discussion