PPP over ATM

Unanswered Question
Sep 2nd, 2009

Dear friends,

When I tried to simulate the ATM network for Ammavan Thomas regarding his question here about the MPLS over PPP over ATM I came across a strange problem.

I was experimenting with two IOS versions for 7200 series on dynamips. I have used the same topology - two routers connected back to back using their ATM1/0 interface.

I have used the following configuration:

R1:

interface ATM1/0

no ip address

no atm ilmi-keepalive

!

interface ATM1/0.1 point-to-point

no snmp trap link-status

pvc 0/61

encapsulation aal5snap

protocol ppp Virtual-Template1

!

!

interface Virtual-Template1

ip address 10.0.0.1 255.255.255.0

On R2:

interface ATM1/0

no ip address

no atm ilmi-keepalive

!

interface ATM1/0.1 point-to-point

no snmp trap link-status

pvc 0/61

encapsulation aal5snap

protocol ppp Virtual-Template1

!

!

interface Virtual-Template1

ip address 10.0.0.2 255.255.255.0

Now, when I use this configuration on IOS 12.3, everything works just fine and there is full IP connectivity between the two routers. The show ip interface brief on R1 shows this:

R1#show ip int brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 unassigned YES unset administratively down down

ATM1/0 unassigned YES manual up up

ATM1/0.1 unassigned YES unset up up

Virtual-Access1 unassigned YES unset up up

Virtual-Access1.1 10.0.0.1 YES TFTP up up

Virtual-Template1 10.0.0.1 YES manual down down

Virtual-Access2 unassigned YES unset down down

However, when I apply the very same configuration on IOS 12.4, there are problems. Note the show ip interface brief on R1 again:

R1#show ip int brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 unassigned YES unset administratively down down

ATM1/0 unassigned YES manual up up

ATM1/0.1 unassigned YES unset up up

Virtual-Access1 unassigned YES unset down down

Virtual-Template1 10.0.0.1 YES manual down down

Note that the interface Virtual-Access1 remains down/down. The interfaces Virtual-Access1.1 and Virtual-Access2 are not created at all. The PPP negotiation never takes place. Simply - the PPP session never comes up.

Is there anything that should be configured differently on the 12.4 version? Am I doing any mistake here? Any hint or suggestion is greatly appreciated!

Best regards,

Peter

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mgonzalezd07 Thu, 09/24/2009 - 14:16

Hi.. I have a Cisco 877 (ADSL Interface) and we work ADSL Technology.. atach the following.

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

interface ATM0.1 point-to-point

pvc 8/81

pppoe-client dial-pool-number 1

the PVC es may possible 8/35 or 8/81.. this number was given by the carrier mode bridge or router depends of the service..

interface Dialer0

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1492

ip virtual-reassembly

encapsulation ppp

no ip route-cache cef

ip route-cache flow

no ip mroute-cache

dialer pool 1

dialer-group 1

no fair-queue

down-when-looped

no cdp enable

ppp authentication pap callin

ppp pap sent-username xxx password xxx

crypto map xxx

ATM0 unassigned YES NVRAM up up

ATM0.1 unassigned YES unset up up

Vlan1 100.2.225.1 YES NVRAM up up

Dialer0 xxx.xxx.xxx.xxx YES IPCP up up

Virtual-Access1 unassigned YES unset up up

the carrier is infinitum (Telmex)

Actions

This Discussion