cisco 2811 hang

Unanswered Question
Sep 2nd, 2009
User Badges:

Hi,


My Cisco 2811 router starts to hang & give the following error.

"Original nvconfig doesn't have a correct magic number recovering from backup."

I need to fix it ASAP. Please someone help me!!!


I've already enter rommon & change confreg to 0x2142 & reset but same problem occur.



Regards,


Raymond

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Peter Paluch Thu, 09/03/2009 - 05:01
User Badges:
  • Cisco Employee,

Hello,


Have you tried backing up the configuration and doing the "erase nvram:" from the IOS? Also, what IOS version are you using? There were some documented problems with IOSes 12.4(6.7) and 12.4(6.6)T.


This might also suggest a problem with the NVRAM - either with the data consistency or a hardware problem. Are you suggesting that even having the configuration register at 0x2142 still causes that output to appear?


Best regards,

Peter


mon_samonte Thu, 09/03/2009 - 21:53
User Badges:

Hi Sir Peter,


Thanks for the reply. I've already done that procedure. I bypassed the config on rommon (0x2142) & try to boot but still same problem. The router boots up but it will take up to 2 hours before it initialize.


Any other suggestions? Is there any possibilities that the ios id corrupted??


Regards,


Raymond

Peter Paluch Thu, 09/03/2009 - 22:51
User Badges:
  • Cisco Employee,

Hello Raymond,


As to the IOS corruption - it is possible but right not I am not quite convinced that it is the cause of your problem. Nevertheless, you could try to download the most recent IOS, erase the NVRAM again and save the configuration - perhaps the new IOS will be somehow able to recognize the corruption and save the configuration correctly.


You have said that your router boots up but it takes up to 2 hours. Interesting. Can you disconnect all networking cables and leave only the console connected, and then reload it to see if it boots faster?


Also, can you post the screen capture of the entire booting process here?


I am still thinking that the most probable cause of your problem is an hardware issue but I'd like to be sure that we have tried every reasonable thing.


Best regards,

Peter


mon_samonte Thu, 09/03/2009 - 23:56
User Badges:

Hi Sir,


Thanks for the reply!


I will load a new version of IOS & see if it will solve the problem. I will keep you updated on the status.



Regards,


Raymond

Peter Paluch Tue, 09/08/2009 - 08:00
User Badges:
  • Cisco Employee,

Hi Raymond,


Did the new IOS do any good?


Best regards,

Peter


Leo Laohoo Tue, 09/08/2009 - 13:44
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Did you install any VPN module or is the VPN module built-in?


Are you using CF >2Gb?

hadelmahmoud Sun, 06/19/2011 - 04:48
User Badges:

Dear Guys,


I have the same problem but this time for the VG224 and I tried the last IOS but it has the same problem can anyone help me?


BR;

skarthic Sun, 06/19/2011 - 04:53
User Badges:

Are you facing problems while bootup or is it after bootup?Is the bootup succesful.

What is the IOS version that you are using. Also could you provide the error message that is logged.

Actions

This Discussion