MacIntosh Configuration for VOIP SPA941

Unanswered Question
Sep 3rd, 2009

I lost my internet connection and my provider gave me new IP settings but now my phone doesn't work.  Do I need to reconfigure my VOIP and if so, how do I do it for MacIntosh?  I use Airport wireless and a router.  I only found PC instructions on-line.  I'm in Africa with a critically ill father in the States and need my phone working asap. Please explain things to me like a 2 year old since most terms are over my head. Thanks for any and all help.  Anne

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
William Childs Thu, 09/03/2009 - 22:23


I assume now that your internet service is back up, as you are able to post on this forum. Please post the model number of your router, who is providing your voip service, the ip address of your phone (can be checked by pressing the button under the envelope, then scroll (using the big button with 4 arrows on it) down to option 9 "Network Settings"/ or just press 9, the ip address of your phone is option 2 on that menu). The phone should automatically register with the service provider regardless of your ip address. The part that controls registration is the registration server settings usually given to you by your voip provider. If at all possible consult with them to see if your phone is registering.

Good Luck Anne,


anneeames Fri, 09/04/2009 - 00:35

Bill, I don't know if this helps, but before we clicked "reset to factory settings" the LED display said something like "searching for DNS". My current IP

address on my Mac is and on the Linksys phone it is  And my system now has two DNS server numbers, one of which is the same as the
phone, but it's grey and the black number is the new one the provider just gave me so I could get back onto the internet.  My ADSL router is Billion 5102S and my internet provider is Mweb (  My voip provider is InPhonex.  Thanks so much for writing.  I hope you can help me.  I desperately need my phone.

anneeames Tue, 09/08/2009 - 12:58

A solution at last!  Good ol' trial and error. I gave up trying to do the configuration on my Mac and used my husband's PC and was able to do all the steps found on the "device configuration" page of the Small Bus. Support Comm.  HOWEVER, the green lights STILL did not come on my VOIP.  But after doing all the reconfiguration on Supra's page (where the directions take you) I noticed tabs that said "Info" and "System" and there I saw a place to enter a "second DNS address."  I inserted the new DNS address given to me by provider when I lost internet connection and VOILA! the lights came on.  Too bad the instructions didn't say this.  Also, I suspect other Mac users may have problems accessing the IP address as directed in the instructions via Safari . If this is true, support ought to know it and offer additional steps to follow.  Bottom line, if this happens to you and you can't complete the steps on your Mac, use a PC, enter everything as directed, including any change in DNS that you may have in the Supra system section.  Hope this saves someone 2 weeks of hair-pulling.


This Discussion

Related Content