SNMP RW Community only shows as RO

Unanswered Question
Sep 3rd, 2009

I'm hoping there's a simple answer to this but I can't seem to get an SNMP Read-Write community to work. I have the following statement in my switch:

snmp-server community test123 RW

Now when I perform a test poll using an IP SLA tool it errors saying it is only a RO community string. I've tried other strings with the same result. I have successfully performed this on other switches but this one does not want to play ball! Is there something obvious I'm missing here?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Thu, 09/03/2009 - 09:28

It would probably be a good idea to get a sniffer trace of SNMP traffic to your device when performing the IP SLA poll from your management app. It could be that the objects being polled do not exist on this device.

craig.juhas Fri, 09/04/2009 - 00:31

I will try performing a sniff but I am based in London and the switches are in Paris and Venice. The problem is I don't even get as far as polling an object. There is a 'Test SNMP' button on the Solarwinds IP SLA Monitor and if I press that I get the error saying the string I've typed is read-only. I typed something completely random and it responds by saying the string doesn't exist so I know the tool is working properly. FYI below is a list of the switches I'm performing the IP SLA on:

Dublin: Version 12.2(25)SEE4 - WORKS

Atlanta: Version 12.2(25)SEE3 - WORKS

St Etienne: Version 12.2(25)SEE4 - WORKS

Paris: Version 12.2(40)SE - FAILS

Venice: Version 12.2(40)SE - FAILS

London: Version 12.2(50)SE - WORKS

I've just done this version check and it seems to me that 12.2(40)SE has a bug in it as the previous and subsequent versions work without issue. Is anyone aware of an issue with SNMP RW with this version?

Joe Clarke Fri, 09/04/2009 - 08:10

First, IP SLA isn't even supported on desktop switch code prior to 12.2(40)SE. But I am not aware of any bugs in 12.2(40)SE that would account for this. It would really be helpful to see exactly what Solariwinds is doing. That would help in searching for bugs.

craig.juhas Mon, 09/07/2009 - 07:09

This isn't IP SLA in Cisco terms of tracking etc. It is simply the name of the Solarwinds product. It allows me to probe a remote device and perform remote monitoring, in my case I am getting a remote switch to ping the data centres in London and Cincinnati. This is put into graphs and gives me an idea of RTD.

I'm not sure exactly what the Solarwinds software SNMP sends to the switch to get it to perform these pings but I'll try to find out...

Joe Clarke Mon, 09/07/2009 - 10:32

No, I'm fairly sure Solarwinds IP SLA product uses IP SLA in IOS devices. It is most likely trying to set an object in the CISCO-RTTMON-MIB, and this is failing. That's why a sniffer trace will be the most useful tool in solving this problem.

One possibility is that the failing switches are running an ipbase image (or other image) which does not support IP SLA source operations.

Actions

This Discussion