Scripting help?? Multiple CSQ and Callback

Unanswered Question
Sep 3rd, 2009
User Badges:

Hi,


I edited a script with Multiple CSQ and leave message for agent and callback.

But i have problem with the callback with multiple CSQ, the customer can leave the message and his number but when an agent became avalaible no phanton call in the queue.


See attachment.


Any ideas???


Thank you



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
robluechtefeld Thu, 09/03/2009 - 10:10
User Badges:

At the beginning of your script, you have set the exception handler for contact inactive exception. But then, after the caller records a message, you terminate the contact. I believe this will trigger the exception handler.


My suggestion is to clear the exceptionhandler just before you terminate the contact using the On Exception Clear command.

Naoufal KERBOUTE Fri, 09/04/2009 - 07:01
User Badges:

Hi,


Thank you for your reply, I tried what you said but no result, and i also deleted the exeption handler from the script item no result.


Any other ideas??


Many Thanks

robluechtefeld Fri, 09/04/2009 - 07:32
User Badges:

Hi,


I don't have a lot of other ideas or suggestions, but I have a couple of questions.


When you are debugging this script, what branch does the script take after you execute the Place Call step?


Also, have you looked at the calling search space for your CTI ports / route points? I assume they are able to dial the 8000 extension, but it would be good to verify.


What type of number is 8000? Is it another CTI Route Point for another application? If so, you would also need to make sure that the calling search space for the CTI ports also includes the partition for the CTI ports. (Because in this case, a CTI port would be calling another CTI Port.) Hopefully that makes sense.


Other than those questions, I would have to suggest you dig into the logs to see if you can find out why the call is not going through.

Naoufal KERBOUTE Fri, 09/04/2009 - 08:01
User Badges:

Hi,


The number 8000 is the route point for my application, and no problem with calling search space and partition.

I worked with the same script but without multiple CSQ and multiple Menu and it's work great, the call stay in the queue since the client hang up and when an agent became availble he receive the call.


You will find the script in the attachment.


I ran a reactive debug i all steps work great, but when the client leave a message and her number for call back the script still waiting for an agent, bellow the value for the variable OuboundContact

"§com.cisco.wf.subsystems.jtapi.TAPIPortGroup$CallImpl§JTAPICallContact[id=104,implId=25025/1,state=STATE_ANSWERED_IDX,inbound=false,App name=TechLine,task=16000000182,session=2000000111,seq num=0,cn=8000,dn=null,cgn=8004,ani=null,dnis=null,clid=null,atype=OUTBOUND,lrd=null,ocn=8000,route=RP[num=0000],TP=8004]§"

and callback number "§com.cisco.prompt.GeneratedPrompt§telephone.number[1001]§"



Thank you



robluechtefeld Tue, 09/08/2009 - 04:13
User Badges:

Sorry, I don't have any other help to offer. I see that your call is being answered by the other script, but without live debugging I can't tell you what is happening.


Good luck. Hope you find your problem.

Actions

This Discussion