Qos config..

Unanswered Question
Sep 3rd, 2009
User Badges:

Hi all..Once again but with diff case.

I have two locations DC & DR connected with two lease line 45+45 Mb.Also configure EIGRP betw these two location for load balancing.

Q. I have one NAS at DC and other replica of that NAS is at DR.High volume of data is transfring betw these server.

I want to configure QOS like 50% of the bw use for two NAS server and 50% for other traffic.


What steps need to be configure for acheiving this............Thanx...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Joseph W. Doherty Thu, 09/03/2009 - 15:42
User Badges:
  • Super Bronze, 10000 points or more

What kind of devices, and their IOS version, connect to the DS3s?

u1kumar2002 Thu, 09/03/2009 - 20:42
User Badges:

Hi Arjun,

There are only few steps to configure the QOS :


1. configure a access list for your NAS server

2. Call that access-list into Class-map.

3. Configure a policy map which can fulfil your requirement of allocation of 50% Bw to that server at any point of time.

4. Apply that policy map to wan interfaces.


May be you will having metroethernet or ethernet connectivity on your end from Service provider.


Ex:

ip access list standard NAS_Server

permit x.x.x.x 0.0.0.0

Class-map match-all NAS

match access-group NAS_Server


policy-map BW_MG

class NAS

bandwidth percent 50

class class-default

fair-queue

exit


apply this cmd on WAN interface


service-policy output BW_MG


show policy-map int fa0/


Try this It should work

arjunsawant Sat, 09/05/2009 - 05:49
User Badges:

Hi,


Thanx for ur reply...

I have one doubt...On which wan interface i have apply service-policy? B'cause on my router i have two wan interface which are in eigrp for load balancing.

I want to assign 50%(45+45=90MB) of bandwidth to NAS.

is it possible?

Thanx...

arjunsawant Sat, 09/05/2009 - 10:25
User Badges:

Thanx.......

I'll try.

Is it require to configure on both router DC and DR?



arjunsawant Sun, 09/06/2009 - 05:28
User Badges:

Hi....

I configure on DC,


class-map match-all NAS

match access-group name NAS_OUT

!

!

policy-map NAS_BW

class NAS

bandwidth percent 50

class class-default

fair-queue

!

!

!

interface FastEthernet0/0

bandwidth 1000

ip address 10.5.1.149 255.255.255.252

duplex auto

speed auto

service-policy output NAS_BW

!

interface FastEthernet0/1

bandwidth 1000

ip address 10.5.1.161 255.255.255.252

duplex auto

speed auto

service-policy output NAS_BW

!

interface FastEthernet1/0

ip address 10.0.0.1 255.255.255.0

duplex auto

speed auto

!

router eigrp 111

redistribute connected

network 10.0.0.0

no auto-summary

!


!

ip access-list extended NAS_OUT

permit tcp host 10.0.0.175 host 10.1.0.75 eq 10001

permit tcp host 10.0.0.176 host 10.1.0.76 eq 10001

permit icmp host 10.0.0.175 host 10.1.0.75 echo

permit icmp host 10.0.0.175 host 10.1.0.75 echo-reply

permit icmp host 10.0.0.176 host 10.1.0.76 echo

permit icmp host 10.0.0.176 host 10.1.0.76 echo-reply

!


But when i send some icmp traffic, it shows only on one interface.


DC#sh policy-map inter fastEthernet 0/0

FastEthernet0/0


Service-policy output: NAS_BW


Class-map: NAS (match-all)

510 packets, 58140 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group name NAS_OUT

Queueing

Output Queue: Conversation 265

Bandwidth 50 (%)

Bandwidth 500 (kbps)Max Threshold 64 (packets)

(pkts matched/bytes matched) 9/1026

(depth/total drops/no-buffer drops) 0/0/0


Class-map: class-default (match-any)

131 packets, 10362 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 256

(total queued/total drops/no-buffer drops) 0/0/0

DC#sh policy-map inter fastEthernet 0/1

FastEthernet0/1


Service-policy output: NAS_BW


Class-map: NAS (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group name NAS_OUT

Queueing

Output Queue: Conversation 265

Bandwidth 50 (%)

Bandwidth 500 (kbps)Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0


Class-map: class-default (match-any)

120 packets, 9918 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 256


Is there any wrong in config?

Pls suggest......

(total queued/total drops/no-buffer drops) 0/0/0

DC#




u1kumar2002 Sun, 09/06/2009 - 21:46
User Badges:

It is ok, Plz check he access-list & make it sure it is correct.

Actions

This Discussion