PSTN Caller ID Pattern on SPA3102 not working

Unanswered Question
Sep 3rd, 2009

Hello all,


I'm having difficulty with this feature. I have a Linksys SPA 3102, with both ports registered with my SIP provider. I've enabled PSTN-To-VOIP. I would like to achieve the following.


1.     If I call my PSTN number from my mobile, I should be given access to the VOIP.

2.     All other telephone numbers should not have access to the VOIP.


My understanding is that this can be configured with the PSTN Caller ID Pattern. However, when I put my mobile number in the field, the PSTN to VOIP gateway cease to function for all numbers. I've confirmed that the CLI is working as I can see my mobile number on the info page.


Has anybody solved this problem?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Alberto Montilla Mon, 09/07/2009 - 06:25

Dear Sir;


Can you activate Debug level 3 on the device and send us the traces? (please set also the debug on SIP, i.e. SIP Debug Option parameters on the [Line] tab).


Regards
Alberto

olorunloba Thu, 09/17/2009 - 10:32

Thanks Alberto,


Find attached the trace logs. I've masked my mobile numbers in the logs. The 078xxxxxxxx number is the one configured in the PSTN caller id pattern.

Attachment: 
olorunloba Fri, 09/25/2009 - 02:49

Hello Alberto,


Have you been able to go through the logs?


Anybody with a solution to this? Or is this a feature that does not work?

William Childs Thu, 09/10/2009 - 03:02

Perhaps when you call the 3102 sees your area code and 7 digit number after and maybe you only put in your 7 digits? Maybe you need a 1 in front of area code+ 7 digit phone number? Have you tried all concatenations of your number?


Bill

olorunloba Thu, 09/17/2009 - 10:34

Thanks Bill, I've tried different combinations, and even used wildcards. It seems that once any character is entered into the field, it no longer grants VoIP access to the PSTN caller (for all numbers).


The info page is not displaying the area code. I do not think this should be the problem.

Actions

This Discussion