SPA-2100 blocking inbound ftp access

Answered Question
Sep 3rd, 2009
User Badges:

Dear Community:


i am using an spa-2100 along with other devices. i have DI-624 router and ftp server software running on a WinXPProSP2 box. when i connect through the router from other macines connected to the router, all is fine. when i connect to my internet connection directly rather than through the router or the spa-2100, all is also fine. in each case, outside users can connect to the ftp server.


when using just the spa-2100 and the internet connection, incoming ftp acccess is blocked by the 2100 since simply removing the spa-2100 from between the internet connection and the windows box provides for direct access to the ftp server software.


what settings in the spa-2100 would be blocking this? what should they be set as?


thanks


freeman-a

Correct Answer by William Childs about 7 years 10 months ago

Freeman,


You could try port forwarding (on the application tab) port 21 to your ftp server. That should fix it. Other than that, there is not a firewall to try to get around.


Bill

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
William Childs Fri, 09/04/2009 - 04:55
User Badges:
  • Bronze, 100 points or more

Freeman,


You could try port forwarding (on the application tab) port 21 to your ftp server. That should fix it. Other than that, there is not a firewall to try to get around.


Bill

freeman-a Fri, 09/04/2009 - 06:30
User Badges:

>Freeman,

>

>You could try port forwarding (on the application tab) port 21 to your ftp server. That should fix it. Other than that, there is not a firewall to try to get around.

>

>Bill


Dear Bill:


that certainly sounds like it could be it. i will check and report back after trying it.


freeman-a


freeman-a Fri, 09/04/2009 - 07:17
User Badges:

>Freeman,

>

>You could try port forwarding (on the application tab) port 21 to your ftp server. That should fix it. Other than that, there is not a firewall to try to get around.

>

>Bill


Dear Bill:


i went to the applications page. i found the port forwarding settings. i entered this:


Port Forwarding Settings

"Enable-yes" "Service name-ftp"  "Starting Port-21" "Ending Port-21" "Protocol-both" "Server IP Address 192.168.10.-0"


i am sure about most of that.

Enable, of course.

Service name, whatever i want.

Starting and Ending Ports, again, whatever i want, but ftp defaults to port 21.

Protocol, TCP is fine, but both is as well.

Server IP Address, not so sure. this allows one to enter only the last octet. and the default is 0. i am unclear what that should be, but think it should remain 0. i am a little unclear as to what this setting is really saying.


thanks

freeman-a


William Childs Fri, 09/04/2009 - 20:35
User Badges:
  • Bronze, 100 points or more

Freeman,


The last octet should relate to the ip of your server. For example:


FTP server IP = 192.168.10.50


Set the last octet to 50. This way the ATA knows to forward the traffic coming in on port 21 (both protocols) to the ip address 192.168.10.50. The rest of your configuration is right.


Good Luck,


Bill

Actions

This Discussion