same source/destination for two gre tunnels

Answered Question
Sep 5th, 2009
User Badges:

is it possible to have two gre tunnels using same source and dest..??


i tried this in lab, the tunnel i configured earlier was up but was not working...




Correct Answer by Peter Paluch about 7 years 10 months ago

Hello,


It is possible but you need to use the tunnel key command to differentiate one tunnel from the other. Otherwise the tunnelled packets are indistinguishable and the router does not know which Tunnel interface they belong under.


So for example:


interface Tunnel1

ip address 10.0.1.1 255.255.255.0

tunnel source fa0/0

tunnel destination 192.0.2.1

tunnel key 1


interface Tunnel2

ip address 10.0.2.1 255.255.255.0

tunnel source fa0/0

tunnel destination 192.0.2.1

tunnel key 2


On the remote end 192.0.2.1, the tunnel keys must be configured in the same way so that the packets are processed by the appropriate tunnel interface.


Best regards,

Peter


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Peter Paluch Sat, 09/05/2009 - 15:13
User Badges:
  • Cisco Employee,

Hello,


It is possible but you need to use the tunnel key command to differentiate one tunnel from the other. Otherwise the tunnelled packets are indistinguishable and the router does not know which Tunnel interface they belong under.


So for example:


interface Tunnel1

ip address 10.0.1.1 255.255.255.0

tunnel source fa0/0

tunnel destination 192.0.2.1

tunnel key 1


interface Tunnel2

ip address 10.0.2.1 255.255.255.0

tunnel source fa0/0

tunnel destination 192.0.2.1

tunnel key 2


On the remote end 192.0.2.1, the tunnel keys must be configured in the same way so that the packets are processed by the appropriate tunnel interface.


Best regards,

Peter


Peter Paluch Sun, 09/06/2009 - 11:43
User Badges:
  • Cisco Employee,

Hello,


This URL is a command reference describing this command:


http://www.cisco.com/en/US/docs/ios/interface/command/reference/ir_t2.html#wp1011711


The following is a quotation from the RFC 2890 where the key extension for the GRE is described:


2.1. Key Field (4 octets)


The Key field contains a four octet number which was inserted by the encapsulator. The actual method by which this Key is obtained is beyond the scope of the document. The Key field is intended to be used for identifying an individual traffic flow within a tunnel. For example, packets may need to be routed based on context information not present in the encapsulated data. The Key field provides this context and defines a logical traffic flow between encapsulator and decapsulator. Packets belonging to a traffic flow are encapsulated using the same Key value and the decapsulating tunnel endpoint identifies packets belonging to a traffic flow based on the Key Field value.


Best regards,

Peter


Actions

This Discussion