NAT overload on asa 5520

Unanswered Question
Sep 6th, 2009

I have a ASA 5520 and would like to know how to setup NAT overload so my internal users can access the internet with the one public IP I have.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
shanemcanuff Sun, 09/06/2009 - 17:34

I try that commands and I was unable to overload, do I need to setup any ACL?

kwillacey Sun, 09/06/2009 - 18:07

You can either nat anything or ur specific subnet

nat (inside) OR

nat (inside)

As long as you have ur nat global ur nat inside

and ur default route it should work

shanemcanuff Mon, 09/07/2009 - 07:42

guess I am missing something cause it did not work for me at all. Can someone look over my config.. plz.. I am using windows 7 and have problems getting to the GUI.


: Saved


ASA Version 7.0(8)


hostname tempasa

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted




interface GigabitEthernet0/0

nameif outside

security-level 0

ip address


interface GigabitEthernet0/1

nameif dmz

security-level 50

ip address


interface GigabitEthernet0/2

nameif inside

security-level 100

ip address


interface GigabitEthernet0/3


no nameif

no security-level

no ip address


interface Management0/0

nameif management

security-level 100

ip address



ftp mode passive

pager lines 24

logging asdm informational

mtu outside 1500

mtu dmz 1500

mtu inside 1500

mtu management 1500

no failover

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0 0 route outside 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00

timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa authentication ssh console LOCAL

http server enable

<--- More --->

http management

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

telnet inside

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address management

dhcpd lease 3600

dhcpd ping_timeout 50

dhcpd enable management


class-map inspection_default

match default-inspection-traffic



policy-map global_policy

class inspection_default

inspect dns maximum-length 512

inspect ftp

inspect h323 h225

inspect h323 ras

inspect rsh

inspect rtsp

inspect esmtp

inspect sqlnet

inspect skinny

inspect sunrpc

inspect xdmcp

inspect sip

inspect netbios

inspect tftp


service-policy global_policy global


: end


rlisiecki Mon, 09/07/2009 - 07:58

nat (inside) 1 0 0 route outside 1 (I think this should be two lines)

nat (outside) 1

route outside 1

shanemcanuff Mon, 09/07/2009 - 08:59

should I be able to ping the outside interface from the inside interface?

Kureli Sankar Mon, 09/07/2009 - 09:10

You mean ping the outside interface from an inside host/pc?

No. You can only ping the closest interface to the PC. If the PC is on the inside you can only ping the inside interface IP.

If the PC is outside you can only ping the outside interface IP on the FW.

That is by design.

As far as your nat lines. both nat and route lines appear as one line. I am not sure how that happened. Pls. make sure

sh run nat

only shows the following

nat (inside) 1

and sh run global

only shows the following

global (outside) 1 interface

These two lines do the overloading that you do in case of routers.

Collin Clark Tue, 09/08/2009 - 05:16

From the ASA can you ping If it fails, do a SHOW ARP and see if you see a MAC to IP mapping. Let us know the results.

shanemcanuff Tue, 09/08/2009 - 06:06

thanks a lot guys I got it to work, I am going to try to pool 3 public IP I have to do NAT overload.

Collin Clark Tue, 09/08/2009 - 06:26

You can only PAT one address. If you use 3 addresses, it will 1:1 NAT the first two addresses and then PAT the 3rd.

shanemcanuff Wed, 09/09/2009 - 13:34

Thanks a lot, I got it to work now. The major problem I was having was that I keep test the ping from the ASA, which keep failing when I test it from a system on the LAN I was able to access the internet.


This Discussion