HTTPS Authentication issue on ASA

Unanswered Question
Sep 7th, 2009
User Badges:
  • Bronze, 100 points or more

Hello experts,


I'm doing authentication on the firewall for HTTP and HTTPS traffic. It is working fine for the HTTP, but it does not work for HTTPS, do I require virtual http? even with that I was not getting the prompt, I was able to access directly... this is my configuration:


test(config)# sho run


ASA Version 8.0(3)

!

interface GigabitEthernet0/0

nameif outside

security-level 0

ip address 192.168.180.96 255.255.255.0

!

interface GigabitEthernet0/1

nameif inside

security-level 100

ip address 192.168.100.1 255.255.2

access-list aaa extended permit tcp any any eq www

access-list aaa extended permit tcp any any eq https

nat-control

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0

route outside 0.0.0.0 0.0.0.0 192.168.180.5 1

aaa authentication match aaa inside LOCAL

username test password xxx encrypted

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ktwaddell Mon, 09/07/2009 - 07:12
User Badges:

Hi


Are talking about https for the asa it self? if so then put in http server enable


Kev

smukhanin Mon, 09/07/2009 - 23:06
User Badges:

No need virtual http for https authentication as I know.

https also supportoted for proxy authentication as http

Actions

This Discussion